Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1

    Need help 2002 virage

    Hi, new to GreenHulk and need help with my 2002 polaris txi.

    I have 2 virage txi pwc both 2002, last weekend while out on the lake 1 pwc died out but restarted only to idle fine but no power.
    Over the next few days I have swaped out every sensor, tps,crank trigger even tried the emm out of the good ski ect... can not get this ski to rpm past idle. Has 120psi compression and good spark. spark plugs are fouled and ski smokes a little when trying to throttle up. No fault or red lights on display are showing. any ideas?
    Thanks.Wipeout


  2. #2
    Good news, while waiting for a reply I decided to remove the fuel pump and found the pressure regulator had fallen out. will be reinstalling it and will post the results.

  3. #3
    You already figured out it the regulator had fallen off, but, it it happens again dont bother taking the tank apart to pull the pump. Just get a pressure regulator for a Kawasaki 1100 STX DI ski. It goes in line in the return line so you dont have to mess with the one in the tank. Unless you pinned that regulator back in the housing it will probably fall out again after hitting some rough water.

  4. #4
    Yes, that was the problem. Very happy to have come across this web site.

  5. #5
    Put the fuel pump back together with the fuel pressure regulator installed and now the pump squeals like there is too much pressure.

    Is it possible the pressure relief is not working?

    ski still idles but no power.

    Also found engine has a water leak from the front case, now I know why the hull has been filling up with water.

    1 step forward 2 steps back.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Well, measure the fuel pressure. Is it correct?

    If fuel pressure is now too high (like nearly 30 PSI or higher) and you installed the Kawasaki inline regulator, then perhaps you installed the Kawi regulator backwards.

  7. #7
    K447
    I followed your link on fuel pump repair, installed the factory pressure relief and know the pump makes noise. If I remove the pressure relief the pump is nice and quite but not enough pressure to I assume run the engine correctly. I do not have a tool to check fuel pressure, need to go buy one today.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    The pump itself may be failing. It can happen.

    If it was me I would be replacing that fuel pump.

  9. #9
    Things just keep getting worse. I checked the fuel pump operation of the working ski and I herd a pop from the tank, now that relief valve blew off and is laying in the tank. I'm really confused, if you ground the brown wire to check operation of the fuel pump why would the pressure relief valve blow off? I now have 2 skis that are broke and not sure why this happening??? So much for taking them out this weekend.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    The pressure regulator mounting is such that it it a weak point inside the fuel pump. The weight of the regulator itself yanks on the hard plastic supporting the internal nipple and eventually the whole thing works loose. Just a matter of time before it pops off under pressure and falls into the bottom of the pump.

    I have described several repair methods that reinforce the nipple and support the regulator so it is less likely to fail again. Another option is to install an external Kawasaki regulator.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help***2002 Polaris virage i***
    By Jamey1985 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 01-28-2012, 03:06 PM
  2. Need HELP with Virage TXI
    By daddyjn in forum Polaris Open Discussion
    Replies: 3
    Last Post: 01-11-2012, 08:08 PM
  3. Need Help 1200 Virage TX
    By FLASH56 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-11-2010, 07:23 AM
  4. need help>>> 2001 virage tx
    By Polaris 01 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-10-2010, 03:29 PM
  5. Need Help With Virage..
    By Alex3012red in forum Polaris Open Discussion
    Replies: 10
    Last Post: 01-17-2007, 07:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •