Results 1 to 2 of 2
  1. #1

    2006 GTX limited lost rpms after new impeller. Can that be fixed?

    Took my ski to the river and had to replace my wear ring and impeller. Before I was getting into the 8000+ range in rpm. But now I'm in the 7500+ range. Why? And can it be fixed?


  2. #2

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,600
    +1
    28
    Areyou sure your replacement prop is the exact same pitch as your old one. How is the fit between the wear ring and prop?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wake 155 rpm and speed loss after new impeller and wear ring
    By 07seadoowake155 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-30-2013, 09:40 PM
  2. 2006 gtx limited how much to replace impeller?
    By paul.s in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-04-2012, 03:16 PM
  3. WTS 2006 GTX Limited w/double trailer, or trade for jet boat
    By badass989 in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 07-02-2008, 12:57 PM
  4. Lost RPM after installing RIVA Power Filter...help!
    By RXP-REX in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-29-2006, 06:39 PM
  5. lost rpms after fiting solas 14/19
    By Top banana in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-10-2005, 06:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •