Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134

    2010 rxt-x 260 melt down

    A few weeks ago my ski overheated, I had the ski sitting on the trailor on the ramp at the beach just letting it run, I had put new antifreeze in the engine as was just letting it get up to temp to check things over. So in doing so I guess my graco filter got clogged with sediment from the ramp. So the next morning I'm thinking all is good jump on the ski and start ripping. Well like I said the graco was clogged and I melted down the exhaust to the point that it melted the support bracket under the muffler, part of the hull, and the frickin exhaust temp sensor melted too.
    My question is after I get the exhaust all squared away with new parts is ther a good way to make sure that there is no blockage in the water lines do I don't have the same issue again


  2. #2
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Glad to see ya back on the forums(not under these circumstances obviously).
    I'm confused as to how the water going to the IC made your exhaust overheat. I think it was Diablo666 had a similar issue recently where his muffler melted too.
    A guy told me CJ @ J&J had a 2010 RXTX for sale with a new motor. I thought it was yours.

  3. #3
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134
    Quote Originally Posted by stuckmoto View Post
    Glad to see ya back on the forums(not under these circumstances obviously).
    I'm confused as to how the water going to the IC made your exhaust overheat. I think it was Diablo666 had a similar issue recently where his muffler melted too.
    A guy told me CJ @ J&J had a 2010 RXTX for sale with a new motor. I thought it was yours.



    My graco got clogged up from running on the trailor down in OC. That cut my flow of water going to the IC and the exhaust manifold. Yeah that isn't mine but yeah there is a I believe Jim said its a 2011 sitting in there for sale.

  4. #4
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    WOW! you didn't get a high exhaust temp alarm first?

  5. #5
    sorry to hear that about your ski!

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Did your exhaust high temp warning go off??

  7. #7
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134
    Exhaust temp warning did go off but I guess by that time the damage was done. Just my luck

  8. #8
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134
    Thanks homie.

  9. #9
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    sorry to hear about your mishap. Go with a TDR water box!!

  10. #10
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by macgyver View Post
    My graco got clogged up from running on the trailor down in OC. That cut my flow of water going to the IC and the exhaust manifold. Yeah that isn't mine but yeah there is a I believe Jim said its a 2011 sitting in there for sale.
    This is why i dont even run one..... Go with the Riva Waterbox you will be happy how its made over the other competitors

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXT-X 260 Pics and Comments!
    By jpt7779 in forum 4-Tec Performance
    Replies: 1415
    Last Post: 06-04-2014, 03:09 AM
  2. Replies: 7
    Last Post: 06-27-2011, 11:38 AM
  3. 2010 RXT-X 260 D.E.S.S problems
    By Mark82 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-07-2010, 11:46 PM
  4. 2010 rxt-x 260
    By bm27 in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-15-2010, 08:51 PM
  5. 2010 rxt-x 260
    By DSmith1178 in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-10-2010, 08:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •