Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    GSXL blows up twice after white pipe transplant

    Had a white pipe put on 1998 GSXL ( silver engine ) since i heard here it was a good add on. All was well for the first 5 minutes until it seized. Shop said it was the oil pump that went out so I had it rebuilt with a replacement oil pump. followed their run in instructions and it died after 3 hours. now the shop says "it looks like last time" but this time it is "detonation" (with premium fuel and 16oz extra oil per 10 gal fuel ). Should this happen just from putting on a white pipe ? engine is stock 947.I did not exceed about 70% throttle, varied speed all the time , allowed warm up and cool dow, revs never exceeded 5800..


  2. #2
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Can you put up some pictures as it just a best guess otherwise.

  3. #3

    Join Date
    Jan 2012
    Location
    Englewood, Florida
    Posts
    47
    find another shop ASAP, you gotta figure out the reason for the first failure before rebuilding. The shop should have known this!

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    Could it be an air leak around the pipe to manifold causing extra leaning and heat on the exhaust side? Possibly cause that one bolt is so hard to get to??

  5. #5
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Location
    Bend OR
    Posts
    1,257
    +1
    1
    Blanket party for the shop. For sure. Just kidding. A good 2 stroke oil is a musts for those engine. The oil pump should be rich for the break in. But with the Extra oil. I don't see it being lean. But 15 gals of gas is alot to 16 oz of oil.. Might be air leak somewhere. Next time Have the shop do a vac check to see if the crank seal are not leaking. I have all so herd 97-98 have a lean spot in the carbs. But I am just guessing. Sorry to here about this. How many hr on the motor too? bottom end?

  6. #6
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    I would think it needed a re-jet? im not sure..anytime you change up you have to know how to re tune it by checking plug color (reading) after an hour or so.
    Was it fine before the pipe change? But anytime you change things it has to be compensated. nature of the beast,only its costly to learn this way..

  7. #7
    Quote Originally Posted by sea-one View Post
    I would think it needed a re-jet? im not sure..anytime you change up you have to know how to re tune it by checking plug color (reading) after an hour or so.
    Was it fine before the pipe change? But anytime you change things it has to be compensated. nature of the beast,only its costly to learn this way..
    they said no rejet necessary when i asked the first time about the white pipe. probably had less than 50 hrs on a complete rebuild 2 years ago at the time it was first put on. it ran perfectly then. i never got to 70-80% throttle as i was breaking it in, though i was told up to 90% was ok for short bursts. no synthetic oil in the gas, but it was api-tc rated Arctic cat oil . the pump had semisynthetic api-tc.

  8. #8
    WICKEDSEADOO's Avatar
    Join Date
    Jun 2009
    Location
    SO CAL
    Posts
    777
    +1
    76
    need to re jet for sure. white pipe spins more rpm.

  9. #9
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    You dont need to re jet because you have not changed the air/fuel ratio the engine just revs 100- 150rpm more.
    The only time you have to re jet is when you add aftermarket air filters which lowers fuel vacuum at the venturi.
    Do you know your jetting specs ?
    Where the carbs cleaned, fuel lines changed over,fuel selector valve cleaned,internal filters changed cleaned or removed ?
    I think this is where your problem lies.

  10. #10
    WICKEDSEADOO's Avatar
    Join Date
    Jun 2009
    Location
    SO CAL
    Posts
    777
    +1
    76
    im sure he is running after market air filters, why would he change to 97.5 white pipe and leave stock air box.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GSXL white pipe
    By sportsjunky in forum 2-Stroke Performance
    Replies: 5
    Last Post: 03-29-2015, 06:54 AM
  2. HELP, Blowed up my xl1200
    By bode1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 30
    Last Post: 10-12-2008, 12:03 PM
  3. GTX keeps blowing up, why?
    By Quad411 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-08-2008, 07:22 PM
  4. 1996 Polaris SLT780 up 1000RPMs after a jump.
    By ktho in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 06-28-2007, 08:10 PM
  5. Engine blow up.
    By jetskidj in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 03-13-2007, 09:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •