Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: rxp won't start

  1. #1

    rxp won't start

    Hey Guys I have a 2004 Seadoo RXP, I was checking for spark I ground the plug a small bolt that hold down the MPEM. As soon as I did that it stopped spinning over. Now if I plug in the DESS I get one long beep and none of the gauges work. Do you guys have any idea what could have happened? Do you think it just jolted the MPEM and lost the key memory? Thanks in advance for the help. Can I fix it my self or do I take it to the dealer


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,181
    +1
    98
    Quote Originally Posted by smokey View Post
    Hey Guys I have a 2004 Seadoo RXP, I was checking for spark I ground the plug a small bolt that hold down the MPEM. As soon as I did that it stopped spinning over. Now if I plug in the DESS I get one long beep and none of the gauges work. Do you guys have any idea what could have happened? Do you think it just jolted the MPEM and lost the key memory? Thanks in advance for the help. Can I fix it my self or do I take it to the dealer
    Depends where you grounded it, if your refering to the ECU on the engine, its mounted in plastic, not grounded. MPEM is under the front hatch by the battery.

    So if you put the spark to the ECU, you may have fried it.

    You can try disconnecting the battery for a few min and reconnect. See if that helps.

  3. #3
    I grounded it on top of the engine on a small bolt. I did a oil change wright before that. Could that cause the problem. I sucked the oil out and added the same. Or less there was a trick of doing that. Is the ski in limp mode

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Check ur fuses.

  5. #5
    there good only ones I found were in the front

  6. #6
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    as said before;

    that intake is not metal so holding the spark plug on the bolt to the ECU probably fried the ECU.

    These skis are very sensitive to voltage spikes, I think they even have warnings on them not to jump start them or charge the battery while its in the ski.

  7. #7
    how can I tell if its not good. does anybody have ecu. Is there a way to test the ecu.

  8. #8

  9. #9
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    check the sea doo classified section or ebay for a new ECU.
    The MPEM might also have been damaged.

    I'm not sure. but the fact that it stopped cranking as soon as you had the spark plug on the ECU leads me to think you fried the ECU.

  10. #10
    isn't there a way to test before I go spend money chasing parts. How do know its not my key not reading my the computer. could the key been rest

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 RXP Won't Start, Chek Engine on the display
    By tpd in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-17-2012, 06:59 AM
  2. Help - '06 RXP Won't Start
    By Flynfox in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-26-2008, 05:35 PM
  3. '05 RXP won't start please help
    By fleahman in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-24-2008, 10:52 PM
  4. RXP won't start
    By wolftrader in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-07-2008, 10:39 AM
  5. RXP won't start!
    By rxpblast in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-12-2005, 03:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •