Results 1 to 3 of 3
  1. #1
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681

    Virage 1200 starting hard?

    I am working on my brother in laws a Virage with the 1200 carb.

    When its cold it starts a little hard. You have to play with the throttle and or choke to get it to fire.
    Then you have to feather the rpms until it goes. After that it runs great! shut it down for a while and it will have the same issues when you go to restart it. I have cleaned the carbs, changed the fuel lines, cleaned the water seperator ect.. All of these looked good.
    Also just installed fresh plugs and battery, now it starts better but still dose it.

    Any ideas on what to check would be great! Thanks!

    The ski runs very strong when its up and running, no problems at all after its warmed up a little.






  2. #2
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Same problem here. I just add primer to the carb and be done with it.
    http://www.shopsbt.com/jet-ski-prime...12-310-01.html

  3. #3
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Sounds like the accel pump. Do you see a good squart when u open the throttle fast? There's alot of threads on them here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Virage Tx starts hard but runs good after its going.
    By hotbird in forum Polaris PWC Performance
    Replies: 9
    Last Post: 05-16-2013, 10:37 PM
  2. 2000 Virage 1200 starting hard?
    By hotbird in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-13-2011, 02:02 PM
  3. 2001 virage starting hard
    By IndyAl in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-07-2010, 08:19 PM
  4. Virage TX 1200 starting problems
    By ld278 in forum Polaris PWC Performance
    Replies: 22
    Last Post: 09-09-2009, 02:22 PM
  5. 1200 Virage TX starting question
    By rjcapo02 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-14-2009, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •