Results 1 to 8 of 8
  1. #1

    Join Date
    May 2012
    Location
    10,000 Lakes
    Posts
    40

    Capsized my ride this past weekend

    Let me just say this...the T3 hull on the RXP-X is bad ass! Was doing about 30 with my buddy on the back, made a sharp left turn and before I knew it I was in the water looking at my ski sitting upside down! It didn't take long to break that cherry!

    I was concerned because there was a small amount of water in the hull after that happened and I don't have a bilge pump but it must have evaporated/steamed off because when I got back to the dock later that evening it was bone dry again.

    Kind of embarrassing but it was damn fun!!!


  2. #2
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    898
    +1
    70
    At least you are enjoying your new ski! The standard siphon hoses removed the water, as soon as you get some speed up it sucks all the water out of the back of the hull, you need a bilge pump as well though!

  3. #3

    Join Date
    Apr 2012
    Location
    Vancouver, Washington
    Posts
    80
    I seen a video of a guy wave jumping in the ocean who capsized. He just turned it over started it up an went on to the jump the next wave ~ like nothin ever happened.

  4. #4

    Join Date
    May 2012
    Location
    10,000 Lakes
    Posts
    40
    Can anyone recommend me a bilge pump?

  5. #5
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    898
    +1
    70
    Yeah mate, you can go buy a rule pump, all different sizes available, I bought the factory seadoo bilge pump kit has everything in it you need and wires straight to the fuse box, very simple and works well!

  6. #6

    Join Date
    May 2012
    Location
    10,000 Lakes
    Posts
    40
    Thanks much!

  7. #7
    JohnnyG.'s Avatar
    Join Date
    Oct 2011
    Location
    Massapequa, NY
    Posts
    138
    +1
    5
    does the aftermarket seadoo rule bilge only work when the ski is on?

  8. #8
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    898
    +1
    70
    It won't turn on until you hit the power button and will turn off after a minute or 2 when shut down if no water in hull otherwise will keep pumping water until all gone then switch off.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Final ride out this past weekend
    By Spades in forum Open Discussion
    Replies: 3
    Last Post: 11-25-2015, 11:10 AM
  2. Texas Racing this past weekend
    By icedog10 in forum Open Discussion
    Replies: 1
    Last Post: 06-09-2010, 09:25 AM
  3. THis past weekend had some fun!!!
    By ArmyRXP in forum Open Discussion
    Replies: 9
    Last Post: 10-24-2007, 06:57 PM
  4. Anyone ride this past weekend?
    By rhorne1053 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 27
    Last Post: 02-16-2007, 11:57 AM
  5. Weird problem with ski this past weekend
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-20-2006, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •