Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Cool In it up to my antlers...

    Allow me to introduce myself.
    I am a Maineiac living in Maryland.I have never really considered purchasing a PWC rode the jet ski's in the early 80's thought they were the coolest thing ever, my wife on the other hand has been dropping hints for years about awave runnerr. As luck would have it I helped a fella out one Sat. morning installing a flag pole as a gift to the man that he sold the house to.
    Long story short he just gifted me 2 ski's a 99 Xl 1200 which I will share my stories about that Gem in the appropriate forum, and the reason I am here an 08 ultra 250. She has been sitting out on the end of a pier uncovered its whole life I suspect with birds bathing in the gunwales and doing you know what every where else. I spent a great deal of time reading these forums while I was going over the Yamaha. I bought both the owners manual and the service manual for it and have been going through that machine all week. Back to the ultra, it was running like crap the man said he had to run it at idle or just above all the way across the river to get it to the pier it is sitting on. I went down yesterday with a new set of unbelievably expensive plugs, some 93 octane gas and a bottle of ethanol helper. It hit instantly and ran as smooth as I would ever expect. Took it out for 15 minutes slow at first and a couple of short bursts up to 6k. On my way back in I started messing with the instruments and found the hours... 14. So help a fella out I have read a lot of threads but so far I have only been able to find images of the manuals for this machine or a paper copy. Can I purchase a digital copy?

    I assume I am going to have to change the oil it must still have its original oil in it what is the break in period for this machine anyway ? I apologies for the questions but Its a gift horse with no documentation. When I pulled the plugs they looked like they were wet and pretty black. every thing else under the seat looks like it has never seen water. By the time I get it out of the water tomorrow night it will have been sitting on a pier with no fresh water. Thats a full week of not being flushed and it being run in brackish water. Out side shes hard to look at but under the seat it looks like a time capsule back to 2008.

    Thanking you in advance for any suggestions or advise.
    Moose


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    You are one lucky sob if the charger is not seized if everything inside looks good. Check all your hose clamps hoses etc. also change your oil and your fuel pump the old stuff out. Do the 2011 pump upgrade mod ASAP lubricste all the csbles and piviot points and give her a good bath.

  3. #3
    The charger seems to be fine. One of the coolest things I think I have ever heard. I only had a very few hours on these types of machines back in the 80's. I ride bikes and have a small boat, but these things are pretty amazing I had it out in a stiff wind with 2 foot chop and it ate it up with out beating me up. It did not come with the WO key but I purchased one. Looks like I have to bite the bullet and have the dealer get that key set up, I couldn't talk them into selling me one of the tools. I feel like a lucky SOB but I have been in the garage every night for a week and will be for the rest of this week. I had to buy a trailer build a cradle on casters winch the thing off one trailer and onto the other. Who knew the things were heavier than the last 4 available girls at the waterin hole. I keep reminding myself how much I have spent on my boat in the last 10 years..lol. Looking forward to getting some before and after pics for you guys.

    Thanks for starting my checklist for me.
    Moose

  4. #4
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    You can buy the key and programer through any oem retailer like here on this site it's like 25$ for the key dongle.

  5. #5
    Quote Originally Posted by FIRE0021 View Post
    You are one lucky sob if the charger is not seized if everything inside looks good. Check all your hose clamps hoses etc. also change your oil and your fuel pump the old stuff out. Do the 2011 pump upgrade mod ASAP lubricste all the csbles and piviot points and give her a good bath.
    This fuel pump upgrade can you post a link to that part or something I couldnt find any information on it. I assume replacing the oil pump with an OEM unit is what you are suggesting?
    I hope both of those are externally mounted Im not looking forward to having to pull any motors anytime soon.

  6. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    looks like tommy forgot to add , he means pump the oil and fuel out and replace it with new fluids
    you can sit back down a relax now..

  7. #7
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by nicjak View Post
    looks like tommy forgot to add , he means pump the oil and fuel out and replace it with new fluids
    you can sit back down a relax now..
    Lol. Yea. what he said

    The pump mod I's for the jet pump not fuel or oil do it now save your motor.

  8. #8
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    You got a good deal pug!

  9. #9
    Deal just got complicated... Lucky SOB gets to break out the tool chest.
    Started going through it, look up into the pump and spotted 2 good sized rocks caught up in there. That tells me they got sucked through and did not exit which would explain the cavitationn I noticed getting it to a ramp to pull it out of the water.
    I am calling the ski's Gift Horse 1 & Gift Horse 2. The Kaw is GH2. Im assuming GH2 ate these rocks and they came through the pump and I can only assume at this point that the prop is most likely damaged, chi ching..lol possible the pump housing hope to hell not.
    I ran it about 32 indicated for 10 minutes to get it out of the water. Since I have no referencence other than some skis in 80's I felt it was hooking up and cruising well but did notice some cavitation that I wouldn't expect from a machine of this caliber.
    I will have to order a SM most likely be a few days before I see it, I will go start transferringring it to a cart so I can work on it, and start pulling the ride plate and what ever else I can get out of the way for inspection.
    Im sure there has to be a bearing and a seal where the prop shaft passes through the hull, any thoughts on whether or not I will have to replace that as well?

    I think you guys will enjoy reading this thread for the next few weeks Im a do it myselfer and I am also a first time ski mechanic. You may well get a couple of good grins out of this. I look forward to your comments as we proceed.

    Moose

    My spell checker is killing my posts..lol (Reason for Edit)

  10. #10
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Thru hull bearings rarely if ever go out. There's a pump for sale in the market place for a few hundred buck as well. Best bet if yours is messed up. In ether case do the 2011 jet pump mod.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 04-24-2014, 10:32 PM
  2. Oil level in Yamaha SHO? Do I need to warm it up?
    By SlowStang305 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-08-2011, 04:28 PM
  3. Hooking a Virage i up to my laptop....
    By lilman573 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 02-03-2011, 11:32 PM
  4. Up to my neck in....
    By SideFX in forum Open Discussion
    Replies: 2
    Last Post: 03-16-2008, 10:03 AM
  5. Water in hull up to engine cover
    By jonstephens in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-25-2005, 12:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •