Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: 1993 sl 650

  1. #1

    1993 sl 650

    I finished my fuel tank set up today. Going to go with a electronic fuel indicator. I re-inspected all my fuel lines (no problems there), and cleaned up the hull the best I could without removing the motor. In the process I found a spring hidden behind the brace directly in front of the motor. Its about 9 inches, and at first I thought it might have held a wiring harness or fuel hoses out of harms way but after very close inspection and 30 mins of fighting with my hood I can't find where this spring goes. Does it have anything to with my oil reservoir? Click image for larger version. 

Name:	ImageUploadedByTapatalk1340909605.805580.jpg 
Views:	75 
Size:	126.6 KB 
ID:	275799


  2. #2
    That spring goes to your hood. Not sure if the location are different but mine hooks on just in front of the oil tank and runs up to the hood on the right side of the ski.

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140

  4. #4
    That's funny. I was fighting with my hood the entire time I was searching where this spring goes. Thank you

  5. #5
    On the rod that holds the hood latch up you will see a small hole where it hooks in, it then goes somewhere towards you oil resivior.

  6. #6
    I got it on in 2 seconds after I looked at the blow up bluefish sent me. I appreciate the help. I hate finding lose or missing parts in something I didn't work on myself

  7. #7
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Everything always comes with spare parts....right?

  8. #8
    Always and I'm sure there is a few more parts in those spots I can see or get to. Guess they will just have to ride until winter gets here. A Complete rebuild is in its future, I really enjoy this ski

  9. #9
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    All those extra parts are robbing you 1/32 of a mph......

  10. #10
    I evened it all out when I lost those foam inserts in the front. Back to where I started. And you can bet when winter gets here I will get that 1/32 mph back. I think I should have a goal with this ski. I'm setting the bar high 55 mph by next summer, WITH a full tank of go juice.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1993 SL 650 won't start
    By hbernier in forum Polaris PWC Performance
    Replies: 13
    Last Post: 07-21-2016, 04:39 PM
  2. 1993 SL 650 - engine cranking when battery connected
    By lemmer18 in forum Polaris Projects
    Replies: 4
    Last Post: 07-13-2016, 08:48 PM
  3. 1994 95 polaris sl 750 to 1993 sl 650 jug swop..?
    By onthewater in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-14-2013, 11:09 PM
  4. 1993 sL 650 Electrical Box
    By dellen10 in forum Polaris Projects
    Replies: 8
    Last Post: 03-31-2012, 05:40 AM
  5. 1993 SL 650 modd help
    By pro170 in forum Polaris PWC Performance
    Replies: 13
    Last Post: 07-09-2009, 08:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •