Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1

    Join Date
    Jun 2010
    Location
    Prosperity, SC
    Posts
    18

    2000 Polaris SLH won't start

    Hey All, I need some help with my 2000 Polaris SLH. Ski ran fine last year but near end of season I would have to push the start button a few times before it would do anything. This year it won't turn over, but just makes a clicking sound. So i started testing things, and found that the starter solenoid (or magnetic switch) as the manual calls it, tested bad. I ordered a replacement, but still doing the same thing. So I am not really sure where to go from here. Battery is good. Is there anything else to try before pulling the starter? And I am having a difficult time confirming where the starter is on the ski and how to remove. The bilge pump stopped working around the same time as the starting issue occured, so could it just be a fuse? I appreciate any help!!!


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    No fuse. If you hear the replay click, have you checked the output with a meter? Sounds to me like you may have either a bad connection (power or ground) or more likely a bad starter.

  3. #3

    Join Date
    Jun 2010
    Location
    Prosperity, SC
    Posts
    18
    How can i check for a bad connection? What are the steps to check the power and ground issue? if it is a bad starter... where is that located? is it under the red exhaust pipe?

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Are you sure the engine or jet pump aren't locked up?

  5. #5

    Join Date
    Jun 2010
    Location
    Prosperity, SC
    Posts
    18
    @ BryanP... I do not know. How would i go about checking to see if the engine or jet pump are locked up?

  6. #6
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Unbolt the jet pump, you should be able to turn the engine by hand. Pump comes out by unbolting the steering cable and pulling the 4 bolts that hold it in.

  7. #7

    Join Date
    Jun 2010
    Location
    Prosperity, SC
    Posts
    18
    Ok guys... it looks like the jet pump is locked. I took the 4 bolts off and the cover and the impeller won't budge. So what now? Can i pull it out and clean it? Are there individual parts that can be replaced, or do i have to replace everything.

  8. #8

    Join Date
    Jun 2010
    Location
    Prosperity, SC
    Posts
    18
    Click image for larger version. 

Name:	2012-07-01_12-41-00_836.jpg 
Views:	56 
Size:	45.7 KB 
ID:	276100 Update... took off jet pump and once off the ski it spins freely with ease. I am attaching pictures of the drive shaft, and impeller to see if you notice anything wrong with them. They look good to me. Engine does not spin at all when trying to turn drive shaft only. So does this mean I have an engine problem now? What should I do next. I read another thread that said to remove the spark plugs and spray PB blaster into and let it sit? Should I try that? and what exactly is PB blaster and are there other items to try first and/or in addition to that.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2012-07-01_12-41-35_925 (1).jpg 
Views:	49 
Size:	60.0 KB 
ID:	276098   Click image for larger version. 

Name:	2012-07-01_12-41-20_222.jpg 
Views:	43 
Size:	80.5 KB 
ID:	276099  

  9. #9
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    If the engine does not spin at all by hand, then there is a problem internally.

  10. #10

    Join Date
    Jun 2010
    Location
    Prosperity, SC
    Posts
    18
    Ok.. Where should i start? Is there something I should look for first? And is it normal for engine to lock up in this manner? Where it worked fine last year once I got it started but now won't turn at all......

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Polaris SLH - No Power, Hard to Start, Struggles to REV
    By ThrottleOut in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-03-2011, 07:24 PM
  2. Please help 99' polaris 700 slh won't start!!!
    By bullxi21 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-22-2011, 01:35 PM
  3. Polaris Freedom won't start.
    By dukeboy73 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 07-12-2010, 12:21 AM
  4. WTB: - - SEAT - - 2000 POLARIS SLH 700 Twin
    By MrRogue in forum Polaris Classifieds
    Replies: 3
    Last Post: 12-15-2008, 09:09 PM
  5. 2001 Polaris Genesis won't start
    By Blink in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 01-11-2007, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •