Results 1 to 4 of 4
  1. #1

    Join Date
    Jun 2011
    Location
    Buffalo, NY
    Posts
    42

    Gas gauge not accurate

    I have a 2000 GTI and I fixed the gas gauge issue with the sticky thread... I had the blown fuse.

    I finally filled the gas tank to the top and the gas gauge is not accurate even if the sea doo sits even on the calm water or trailer..

    Any ideas on how to make it more accurate?


  2. #2
    change the sending unit or gauge because something is not reading right..

    Or just be happy it works..

  3. #3

    Join Date
    Jun 2011
    Location
    Buffalo, NY
    Posts
    42
    Do you think something can be wrong with the float?

  4. #4
    could be missing a magnet - I would of assumed you looked..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trim motor/gas gauge not working
    By towerygl in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-26-2013, 10:06 AM
  2. gas gauge not working
    By Steeler4life in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 07-27-2011, 08:39 PM
  3. 2000 kawasaki ultra 150 gas gauge not working HELP
    By dlimz in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 05-22-2010, 08:34 PM
  4. bilge, trim, and gas gauge not working!!
    By sebas54 in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 05-08-2009, 09:07 PM
  5. gas gauge not working
    By great lakes gpr 1200 in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-31-2006, 08:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •