Results 1 to 5 of 5
  1. #1

    2008 ultra 250x idle problem please help

    went out for a run and in middle of the run i stopped and noticed my idle was idling around 2000 rpm , so when i got home i flushed it and with no load its idling at 4000 rpm , what can cause this ?

    i took off the sensor on top of carb and nothing changed so im thinking it might be that but im un sure , please help a brother out .

    all hoses and cables are in place , no codes on dash either

    thanks guys


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,158
    +1
    600
    Quote Originally Posted by benrock250x View Post
    went out for a run and in middle of the run i stopped and noticed my idle was idling around 2000 rpm , so when i got home i flushed it and with no load its idling at 4000 rpm , what can cause this ?

    i took off the sensor on top of carb and nothing changed so im thinking it might be that but im un sure , please help a brother out .

    all hoses and cables are in place , no codes on dash either

    thanks guys

    OK
    1. Take front seat off
    2. Push the key in till it beeps
    3. Now remove the key and you should hear a series of click / ratting coming from the top of the throttle body ( carby I guess u are calling it ,on the RH side of the engine where the throttle cable goes too )

    tell us if you here the noise please

    Waz

    then pull

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    maybe its those 4 pre heat things with wires going to them on the manifold, since it has a carby lol sorry waz will leave it be

  4. #4
    yep sirbreaksalot , it was that pc on the carb , i had to take it off and clean it and smack it around a little and now i get that clicking , i guess it adjust to let the right amount of air in , thanks guys back in biz

  5. #5
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,158
    +1
    600
    Quote Originally Posted by benrock250x View Post
    yep sirbreaksalot , it was that pc on the carb , i had to take it off and clean it and smack it around a little and now i get that clicking , i guess it adjust to let the right amount of air in , thanks guys back in biz
    order a new 1 as it will fail again

    Waz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 Kawasaki 250x power loss PLEASE HELP
    By gman48 in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 09-25-2016, 07:19 AM
  2. Replies: 2
    Last Post: 07-22-2015, 07:23 PM
  3. Kawasaki ultra 250x bogging issue, please help me :(
    By j_selby in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 01-07-2014, 10:12 AM
  4. 2008 ultra 250x boost problem
    By benrock250x in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-31-2012, 09:51 PM
  5. 2008 Ultra 250x Crazy Problem-Makes no sense.
    By Campo5474 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-01-2010, 08:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •