Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Jun 2012
    Location
    Eudora Ks
    Posts
    36

    2002 polaris freedom NO SPARK

    Ok,

    i just purchased a FREEDOM that has a SBT rebuilt motor with only five hours on it, they had it on the lake this year once
    and it lost spark, i was told that that these are known for the pick up coil, or stator fail most times but i know my ATV's
    but i have alot to learn about PWC's i am a nut for information so any help suggestions how tos manuals etc would be great.

    also safest/best place to buy parts etc.


    i am also trying to find a manual if anyone has a digital copy great, but if not best place to buy one.

    thanks agiain i cant wait to get out on the water,







    i'm new here, my first ski was a polaris slt 750 that took me 6 weeks to get running and while i was happy with myself
    the first freeze hit a well there went the that ski.


  2. #2
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Welcome to GH!

    First off, electrical system on these red engines requires battery to sustain at least 10.6v while cranking to produce sparks. Be sure to verify that there's enough juice in your battery first. If battery is good and still no spark then read up the link below:
    http://www.greenhulk.net/forums/showthread.php?t=15437

  3. #3

    Join Date
    Jun 2012
    Location
    Eudora Ks
    Posts
    36
    the battery was replaced shortly before this issue, any chance anyone has pictures? real or pdf.

    i've heard of a 9volt trick and other thoughts but nothing on screen i can find.

    is there a box other then just the CDI? so i can start testing? a;sp sp,ething about a jumper wire mod?

  4. #4

    Join Date
    Jun 2012
    Location
    Eudora Ks
    Posts
    36
    just purchased a manual so no worries there, but still looking for suggestions and a starting point.

    i hate throwing parts , or we call it blanket diagnostics.

  5. #5
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Spend a little time going thru link I previously posted. Step by step testing instruction and all electrical info is in there.

  6. #6
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Quote Originally Posted by loonatik View Post
    Spend a little time going thru link I previously posted. Step by step testing instruction and all electrical info is in there.
    +1

  7. #7

    Join Date
    Jun 2012
    Location
    Eudora Ks
    Posts
    36
    ok, i have tested the hall sensors or pusler triggers what ever yuo call them with the 9V set up

    what should be the next check? cdi stator? or the L505 thing?

  8. #8

  9. #9

    Join Date
    Jun 2012
    Location
    Eudora Ks
    Posts
    36
    OK, i have tried to follow some of the testing on the CDI i feel i'm making this harder then it should be but anyways.
    Click image for larger version. 

Name:	2012-07-09 20.36.17.jpg 
Views:	138 
Size:	73.6 KB 
ID:	276858

  10. #10

    Join Date
    Jun 2012
    Location
    Eudora Ks
    Posts
    36
    i tested power coming into the cdi i dissconnected the black/yellow wires to test the sart/stop switch, i tried the 9volt battery to see if i get spark and nothing so i'm assuming by the sheet that the stator is bad. by trying these steps http://www.greenhulk.net/forums/showthread.php?t=15437

    now on the wires i was testing i was getting power 10.95v while turning over the motor.

    i feel i'm inept but, i think ive gone the right steps but electrical is my weak point, i'm more the grease,carbs pistons type,lol

    being the price of the parts i konw ive read through all of these a ton of times over the last couple weeks but i hate being wrong and when it can be an expensive pain in the ass , do i need to update the whole system? just the stator?

    i plan on ordering the small board inside the box due to some corrosion i noticed on the rear of it, any suggestions please, i want this ski to be a long term fun for my whole family and broken just isnt very fun for my 4yr old daughter who cant wait to ride it and even helps me work on it. she has been paing enough attention and actually asked me when i came back in if it was the CDI or the stasor,lol.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 polaris virage, no spark I have all test measurments.
    By Simtech in forum Polaris PWC Performance
    Replies: 29
    Last Post: 10-03-2014, 12:00 PM
  2. 2004 polaris freedom no spark and battery is discharging
    By Allencool in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-29-2013, 11:05 AM
  3. 2002 polaris freedom no fire on brown wire wile crancking on cdi
    By Ynot63 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 07-27-2013, 05:17 PM
  4. 2004 Polaris Freedom - no spark
    By Brandonc93 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 05-24-2011, 05:16 PM
  5. 2002 polaris virage no spark
    By maples32 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-13-2008, 09:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •