Results 1 to 7 of 7
  1. #1

    Join Date
    Jul 2012
    Location
    Tucson,az
    Posts
    10

    Exclamation Please help seadoo xp problem

    Mpem problem??

    Hi everybody I'm new to this forum but I was hoping somebody could steer me in the right direction. I have a 96 seadoo xp 787 that I'm having problems with. The previous owner tried to Hotwire the ignition because the key went bad. I replaced the key and it won't marry to the ski. I also Reconnected the wires to the ignition and heat wrapped them. Could the wire splice effect the olms going to the mpem causing it not to work?? Also I checked all the fuses front and back and they were all good. I'd really appreciate any advice anyone has on this


  2. #2
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Did you get the key programmed to the ski?

  3. +1 by:


  4. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,268
    what did you use to "marry"the key. It is assumed that "marry" means that you programmed it with one of the available sstems. BTW..there ain't no way to hotwire a seadoo ignition that uses a MPEM. There are some third party cdi systems that don't require a programmed key..so more details will gain you some useable solutions

  5. +1 by:


  6. #4

    Join Date
    Jul 2012
    Location
    Tucson,az
    Posts
    10
    That's what they called it at ride now. I wasn't really sure I've never heard that term either. But all they said was that they couldn't get a connection to program the key

  7. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,268
    Quote Originally Posted by SJallday86 View Post
    That's what they called it at ride now. I wasn't really sure I've never heard that term either. But all they said was that they couldn't get a connection to program the key

    well that explains it..whatever system is used reads data from the mpem, adds the unique number of the target key to the mpem data and then rewrites that data tot he mpem memory. Then when the key is attached, the mpem checks the number..if it matches one in mpem the mpem allows the engine start.

    The mpem may have been damaged by the "hot wire" attempt.

  8. +1 by:


  9. #6

    Join Date
    Jul 2012
    Location
    Tucson,az
    Posts
    10
    Thanks a lot that would explain a lot. I just wanted some insight before I spent a couple hundred dollars

  10. #7

    Join Date
    Jul 2012
    Location
    Tucson,az
    Posts
    10
    When you mentioned a third party CDI system where would I find something like that and is it cheaper?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please help - 2000 XP problem...
    By SinWolf in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-19-2016, 10:21 AM
  2. 96 seadoo xp problem please help
    By dynasty8314 in forum 2-Stroke Performance
    Replies: 15
    Last Post: 07-02-2010, 02:43 PM
  3. 93 seadoo xp problems
    By b93xp in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-17-2008, 11:07 PM
  4. Please help! 96 XP plumbing
    By JacRae in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-24-2007, 07:16 AM
  5. Please Help with XP beeping
    By lynchie23 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-21-2007, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •