Results 1 to 7 of 7

Thread: a little lag

  1. #1

    Question a little lag

    Not sure but i noticed a little lag when opening the throttle after installing my rd 612-18004, i am running the riva B1 on my 2011 fzr with about 7 hours.
    I read some posts on increasing the tubing size but in my case i am using the oem connections.
    also i had rd R3 flash my ecm

    not sure what to think


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by peterj59 View Post
    Not sure but i noticed a little lag when opening the throttle after installing my rd 612-18004, i am running the riva B1 on my 2011 fzr with about 7 hours.
    I read some posts on increasing the tubing size but in my case i am using the oem connections.
    also i had rd R3 flash my ecm

    not sure what to think
    how many rpm are you turning and by any chance do you know were your afr's are at. I have used that intercooler many times with awesome results, A little more details with the mods and maybe we can help you figure out the problem.

  3. #3
    hi jim, it just happens when i am at idle and give it the gas, otherwise it is perfect, from the idle and it is about a fraction of a second hesitation thats it.
    also ive been busy, but i intend to get out early and get some numbers mph, rpms, boost, afr. it is too trafficky here in long island unless i am out at like 7 am.
    i was planning on this morning but it was raining, i plan on sat 630 or 7 am, i will follow up.

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by peterj59 View Post
    hi jim, it just happens when i am at idle and give it the gas, otherwise it is perfect, from the idle and it is about a fraction of a second hesitation thats it.
    also ive been busy, but i intend to get out early and get some numbers mph, rpms, boost, afr. it is too trafficky here in long island unless i am out at like 7 am.
    i was planning on this morning but it was raining, i plan on sat 630 or 7 am, i will follow up.
    sounds good.

  5. #5
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    So when you stamp the throttle it hesitates a little while before it starts to pull really hard or does pull really slowly through the whole RPM band ?

  6. #6
    aside from the little hesitation from intially standing still it pulls very nice through out the whole rpm range

  7. #7
    ok here are my numbers, a little confused about my speeds and disappointed on how lean i am running at wot.
    rpm 7680, afr 11.9, 62.8 mph
    rpn 8000, afr 12.3, 73.4 mph
    rpm 8140, afr12.5, 75.4 mph
    rpm 8200,afr 12.5, 75.9 mph
    all speeds on gps, 4 bars of fuel.
    also my boost did not go above 10 lbs.

    see my previous post " Finally my 2011 FZR after all my work installing upgrades"
    just search on peterj59.

    Also does anyone know how i can richen my afr, i.e. i am using the R3 flash. maybe go with powershot or larger flowing injectors.


    R Series DYNAFLY 6S5-YAM:YSDF – 13-22 prop
    R-D Perf PRO SERIES IC KIT…612-18004………
    R-D Perf FZR ENGINE / INTERCOOLER COOLING KIT 18001
    R-D Perf ANTI-CAVITATION CONE FZR…162-18000
    R-D Perf O2 SENSOR MT
    Stock OEM nozzle
    R-D Perf R3 ECM REPROGRAM FLASH
    R-D Perf Lithionics Racing Lipo Battery:
    R-D Perf FZR AQUAVEIN INTAKE GRATE…
    R-D Perf FZR PUMP SEAL KIT
    R-D Perf FZR SPONSON KIT
    Jim's Performance VX RIDE PLATE W/MODIFICATIONS
    Riva Racing FZ BLOW OFF VALVE KIT RY17040-BV
    Riva Racing FZ B1 SC IMPELLER 11.5 PSI…RY17040-SCI-B1
    Riva Racing FZ HD SC SHAFT KIT..Gen II
    Riva Racing FREE FLOW EXHAUST KIT… RY16040
    Riva Racing POWER FILTER KIT…..RY13040
    Auto Meter PROCOMP BOOST GAUGE
    Inovate Mtr Sports AIR FUEL RATIO GAUGE
    2 FLO RITE VENTS

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Little Lag time in response..
    By Chucke.b in forum Sea Doo Spark
    Replies: 19
    Last Post: 08-27-2015, 09:29 AM
  2. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM
  3. My little experience ends the towing debate for me.........
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-14-2005, 05:45 PM
  4. A little OT: why do my tie-downs keep coming loose?
    By ToeSurf in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-01-2005, 11:40 AM
  5. Just a little FYI
    By watermedic in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-23-2005, 12:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •