Results 1 to 5 of 5
  1. #1

    2003 SeaDoo GTX 4TEC SC Intermittent Starting Problem?

    Hi,

    I have a 2003 SeaDoo GTX 4TEC SC and I am having an intermittent starting problem. When I put the lanyard on the post all the gauges turn on, fuel pump kicks on and all. Sometimes it will crank right over but other times nothing. No clicking or anything. Once it starts you can shut it off and start it back up until you pull the lanyard. Any ideas what this could be? The post was replaced last year...
    Last edited by PWC-Terminator; 07-03-2012 at 12:33 PM. Reason: Spelling


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Dess post not making contact all they way or starter relay going bad.
    Check all ur battery connections too.

  3. #3
    R-Doo's Avatar
    Join Date
    Sep 2006
    Location
    Minnesota
    Posts
    833
    +1
    77
    My 06 RXT had the same problem. It was the starter relay. Easy fix if it's not 95 degrees out when you swap it.

  4. #4
    Ok sounds like I'm going to go get a starter relay today then and see how that goes. However I did notice something today when I was toying around with it. When I put the lanyard on and it gives me two beeps it will start every time. The times when it does not start it will just give one loud beep when the lanyard is inserted. But even when it gives the loud beep I can still hear the fuel pump kick on every time I hit the start button. Just no starter... Any thoughts?

  5. #5
    R-Doo's Avatar
    Join Date
    Sep 2006
    Location
    Minnesota
    Posts
    833
    +1
    77
    It's not the fuel pump kicking on but the starter relay energizing. It just isn't making a good connection.
    There are a few threads on this issue and I think it was determined there was a bad version of relay. Doo changed the design and color of the assembly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 Seadoo GTX 4tec Problem Please Assist
    By PWCaudio.com in forum 4-Tec Performance
    Replies: 23
    Last Post: 07-26-2015, 10:03 AM
  2. seadoo gtx 185 2004 strange starting problem
    By howellsy42 in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-09-2015, 04:50 PM
  3. 2003 Seadoo GTX SC REVS AT 6500 TO 6650 but top speed only 42 mph
    By gp1200nseadoogtx in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-02-2011, 09:25 PM
  4. 2003 seadoo gtx sc mid acceleration pausing
    By ryck80 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-10-2011, 09:08 AM
  5. 2003 GTX 4Tec SC Oil Light prob.
    By 03gtx01 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-10-2008, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •