Results 1 to 8 of 8
  1. #1

    Join Date
    Jul 2012
    Location
    Birmingham, AL
    Posts
    13

    2003 SEADOO GTX SUPERCHARGE, HITTING 8000 RPM and only 59-60 MPH?? HELP

    I have just bought a 2003 GTX SC and it is hitting 8000+ Rpm topping out and only 58-60 mph topping out... What could be the problem, if there is a problem...I have not used a gps to test actual speed but i am going to do so this weekend... Could it be the prop that is on it?

    I am new to the seadoo world but I am trying, just need alittle help! !

    Thanks guys!!


  2. #2

    Join Date
    Apr 2011
    Location
    Elliott Australia
    Posts
    36
    That sounds a little high in the rpm range? has it been modified? the stock ecu on the 03's limits it at 7600 rpm, stock they are only good for about 60 mph, but if your on the limiter it may be your prop or wear ring? is there a visible gap between them, you shouldn't realy be able to see a gap if you shine a torch up the exit nozle end, but the only real way is to get a set of feeler gauges and measure the gap between. thats my 2 cents worth hope it helps you out.

  3. #3

    Join Date
    Jul 2012
    Location
    Birmingham, AL
    Posts
    13
    I rode it again on the 4th and it was running fine... 7500+ Rpm at 58- 60 Mph... the only thing on take off it had a little bit of a pop or stutter not the motor but sorta like it wasnt hooking up. is that what people mean by cavatation and the wear ring being bad? Just trying to maintain this seadoo since i have just bought it.
    Thanks For The Help!!!

  4. #4
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Quote Originally Posted by jlilla815 View Post
    I rode it again on the 4th and it was running fine... 7500+ Rpm at 58- 60 Mph... the only thing on take off it had a little bit of a pop or stutter not the motor but sorta like it wasnt hooking up. is that what people mean by cavatation and the wear ring being bad? Just trying to maintain this seadoo since i have just bought it.
    Thanks For The Help!!!
    You most likely have a plastic jet pump on it. they are known to do this.
    Replace it with a metal one and that should fix the issue.

  5. #5
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    yes that is cavitation, engine revving high , but not pushing any water.
    it is because air bubbles around the impeller basically let it slip without providing any thrust.
    air bubbles can be caused by bad wear ring or impeller or bad accordion boot on the drive shaft.
    most likely on your ski is tha the wear ring is worn, this is caused by the platic pump housing that can flex under load, which causes excessive wear ring wear.
    you can flip the wearring around once to get fresh plastic over the impeller, this will provide a very tight fit for the impller and fix the cavitation.
    or you can get a aluminum pump housing form any 2004 -2007 rxp rxt that will stop the flexing, however you will still need to flip or replace the wear ring, and the housing is kinda expensive, if you buyone used already assembled, it can cost 350ish or more, new 700+ installation isnt that hard if you are mechanically inclined.

  6. #6

    Join Date
    Jul 2012
    Location
    Birmingham, AL
    Posts
    13
    I am gonna ride the sea doo till the end off the weekend and try to change the wear ring... I am some what mechanically inclined so I dont think I will have a problem, but at the same time this will be the first time taking a wrench to a sea doo.. are there any tips to changing out the wear ring? Where do I start? Are there any mistakes to watch for? How long should the job take?

  7. #7

    Join Date
    Jul 2012
    Location
    Birmingham, AL
    Posts
    13
    Try to change the wear ring Sunday**

  8. #8

    Join Date
    Apr 2012
    Location
    seffner fl
    Posts
    68
    +1
    3
    its pretty easy, theres a guide in the how to. i have the same ski and swapping the wear ring didnt fix the cavitation issue for me, nor did carbon seal or accordion boot. i just bought a used aluminum housing and put it on with a new wear ring and has solved my problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 seadoo gtx supercharged
    By Tatgun in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-29-2014, 09:41 PM
  2. 2003 seadoo gtx supercharger
    By Timapple in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-21-2014, 11:55 PM
  3. 2003 Seadoo GTX Supercharged 36hrs link
    By daniel3535 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-25-2013, 12:56 PM
  4. Replies: 5
    Last Post: 07-04-2012, 09:59 AM
  5. FS: 2003 Seadoo GTX Supercharged 4-Tech
    By PWCaudio.com in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 06-28-2008, 05:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •