Results 1 to 2 of 2
  1. #1

    GP1300r is bogging

    Sorry if this a repost. I did do a search and found a few other similar posts but nothing asking the same question.

    A friend has a 04 Yamaha GP1300r. When he bought it had the Riva EFI control on it already. He replaced the 3rd piston, sleeved, and bored. He put it in the water and it would just fall on its face. He has been messing with the adjustments on the control unit (got a manual on it from Riva) and has the rev limiter cranked all the way up but it still will not go past like 6000-6200 rpm. He said when you start going and pull back the throttle, it's starts out like its going to take off like it should, then just drops, topping out around 52 mph. It just feels like there should be more power but its bogging down.

    Thanks for any suggestions!


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by charger35v6 View Post
    Sorry if this a repost. I did do a search and found a few other similar posts but nothing asking the same question.

    A friend has a 04 Yamaha GP1300r. When he bought it had the Riva EFI control on it already. He replaced the 3rd piston, sleeved, and bored. He put it in the water and it would just fall on its face. He has been messing with the adjustments on the control unit (got a manual on it from Riva) and has the rev limiter cranked all the way up but it still will not go past like 6000-6200 rpm. He said when you start going and pull back the throttle, it's starts out like its going to take off like it should, then just drops, topping out around 52 mph. It just feels like there should be more power but its bogging down.

    Thanks for any suggestions!
    by any chance do you know were the setting are at.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My 2005 GP1300R is not going faster than 38mph
    By jadamoi0619 in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 07-19-2011, 02:16 AM
  2. gp1300r is not turning on
    By titofromnj in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 07-18-2010, 03:27 PM
  3. SPX is bogging under load
    By DKFox in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-14-2010, 05:20 PM
  4. New GP1300R is out !!!
    By RiverDad in forum Yamaha PWC Performance (2-stroke)
    Replies: 53
    Last Post: 08-23-2006, 07:53 AM
  5. GPS's an 06 GP1300R, is this a good number?
    By NeverEndn in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-21-2006, 04:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •