Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    Seadoo rxp 215 Dead! No life at all. PLEASE HELP!!!

    I ran my rxp last weekend and it ran fine with no problems. Parked it in my garage all week and tried to start it today and got nothing. No lights, no beeps, no gauges, no buzzing, no clicking, etc... I checked the battery and it read 12.8v and started checking fuses... all good. I have 12.8v from the 30A fuses to the mpem ground and I've tried other des keys... Still no life. Any suggestions? should I check voltage somewhere else?


  2. #2
    Its a 2004 bone stock btw

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Check the battery connections. Take them off and wire brush them and re connect.
    Then if nothing try to jump your starter relay.
    It's easy with a screw driver or plyers..
    It could also be a bad dess connection.
    Try moving the key back and forth with it on the dess pole.
    Hope I helped...

  4. #4
    so I left the key in and forgot about it. after about an hour I went into the garage and it was beeping but wouldn't start. after I pulled the key and put it back everything was back to normal. Now I'm worried it will happen on the water. any ideas?

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Dess post is bad.

  6. #6
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Quote Originally Posted by wotxxxsd View Post
    Dess post is bad.
    +1

  7. #7
    I think you're right. It stopped working again but if I forcefully "wiggle" the dess post with the key on it sometimes flashes the gauges and sometimes comes on. Thanks!

  8. #8
    Or magnet in key is getting weak. THere is a ring magnet in the key, which pulls in the reed switch in the DESS post to turn on the power to read the info off the key.

    Quote Originally Posted by wotxxxsd View Post
    Dess post is bad.

  9. #9
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    its a bad key!!! the post is fine, 04-05 had keys that failed all the time

  10. #10
    The learner key didn't work either.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 08-07-2016, 09:26 PM
  2. Replies: 0
    Last Post: 08-07-2016, 07:32 PM
  3. 2000 Seadoo GTX RI no signs of life at all
    By j4bs4209333 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-12-2015, 12:55 PM
  4. Seadoo RXP 215 at 70.2 mph
    By bhdien in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-12-2014, 05:27 PM
  5. Replies: 9
    Last Post: 04-14-2013, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •