Results 1 to 4 of 4
  1. #1

    Join Date
    Sep 2011
    Location
    Toronto
    Posts
    17

    Help with chips in haul

    hi, i'm a first year owner of a used f12 and was washing my ski today when i noticed a few small chips (maybe 1/2") in the rear of the hull.

    pretty sure they were not there when i purchased it and don't recall doing anything stupid that would cause the chips.

    any ideas what may of caused them, so i don't repeat?

    should i be concerned to get fixed and/or is it something i can leave as is or fix myself?

    thanks rob

    Click image for larger version. 

Name:	IMG_9938.jpg 
Views:	46 
Size:	21.1 KB 
ID:	276398Click image for larger version. 

Name:	IMG_9939.jpg 
Views:	46 
Size:	50.2 KB 
ID:	276399
    Last edited by seabird; 07-07-2012 at 04:42 PM.


  2. #2
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    Go to West Marine and buy some Marine Tex. It is the easiest to use and will match your white hull.

  3. #3
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    You need to put a little something on that as it is right through the gel coat. I would do as said above. Also it would be in your "hull", as haul is a verb.

  4. #4

    Join Date
    Sep 2011
    Location
    Toronto
    Posts
    17
    Thanks for the feedback. Ended up buying marine goop and it worked out well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help with alignment in NC
    By greens1098 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-14-2010, 10:03 PM
  2. Need help with bendix in SoCal
    By dankyfx1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-11-2009, 08:23 PM
  3. Help With 4 IN Kanaflex install NEED HELP
    By Bigcat1 in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-07-2009, 06:34 PM
  4. Help with break-in for GP1300R
    By Pale Rider in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 03-21-2008, 08:46 PM
  5. Need help with AMP hook up in car
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 12-27-2006, 05:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •