Results 1 to 8 of 8
  1. #1

    Fuel gauge always reads low fuel - Ficht fuel pumpp

    I have a 1999 Genesis 1200 Ficht fuel injected unit and the fuel gauge reads low fuel all almost all the time even when it is full.

    I had to put a new fuel pump assembly in two years ago and the sender comes with it. The new fuel pump/gauge don't even have that many hours on it.

    What else should I look for, the MFI works fine as far as everything else, just the fuel gauge reads low and the light keeps blinking because it thinks its low.

    Thanks in advance for any help.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Is it possible the new fuel level sender was damaged when installed?

    That float arm is rather floppy and the sender itself is exposed on the outside of the pump body.

    You can disconnect the fuel pump connector and measure the ohms between the two sender signal pins (the pins that do NOT connect to Red/Purple and Brown).

    240 ohms indicates an empty tank.
    33 ohms signals a full tank.

    If your meaured sender ohm reading is much greater that 240 or reads open circuit then the sender has a problem.

  3. #3
    Great, thats what I will try. It actually started doing it end of last summer so I pulled the fuel pump assemby out this spring just to see if I could see anything obvious but I didn't, everything looked good. It worked fine for probably a year after I installed it new. I will pull it again and use a ohm meter on it now that I know what the ohms should be. If the sender is bad is there anything i can do to fix it without replaceing the whole fuel pump assembly again, they are pretty expensive?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    I do not recall if the little float arm/sender portion is removable on those pumps. If it is, you may be able to find another 'bad' fuel pump with a good float/sender section.

    Do you still gave your original fuel pump?

  5. #5
    No, like a dummy I threw it away after replacing with the new one, now I wish I had it because the sender worked fine on it. After years of saving old parts I found out they just took up room and you never used them anyway. Now I wish I had it becaue I have a feeling that is whats wrong with the new one. I will find out for sure when I get time to use a ohm meter on it.

  6. #6
    Well I just got the ski out for summer and yes the sender seems to be all over the place on the ohm meter, anybody know where I can find a new one anymore.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by Hayszuki View Post
    Well I just got the ski out for summer and yes the sender seems to be all over the place on the ohm meter, anybody know where I can find a new one anymore.
    Good used fuel pumps are available, and you don't even need good, just one with the sender intact.

    Have a look in the Classifieds on here, for starters.

  8. #8
    Quote Originally Posted by Hayszuki View Post
    Well I just got the ski out for summer and yes the sender seems to be all over the place on the ohm meter, anybody know where I can find a new one anymore.
    Will do, I was wondering if anybody would still have a new one on a shelf, or were they ever available without buying the whole fuel pump assembly?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 RXT Fuel Gauge Issue Always Reading Full
    By relic hunter in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-18-2017, 07:00 PM
  2. 2000 GTX fuel gauge not reading
    By beachy1122 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-02-2015, 03:14 PM
  3. Ultra 150 Fuel sending unit replacement (always reads empty)
    By jpoe6 in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 04-04-2012, 09:41 AM
  4. Spedometer reading low
    By Kevan in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-03-2010, 03:22 PM
  5. Always Read the Hazmat Form First
    By howestek in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-22-2006, 01:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •