Results 1 to 2 of 2

Thread: S/C clutch slip

  1. #1
    Lightning Struck's Avatar
    Join Date
    May 2011
    Location
    Davenoprt Iowa
    Posts
    714
    +1
    10

    S/C clutch slip

    Has anyone had a sprag slip? I'm tracking down what seems like a WOT.throttle cut, but the limiter in the Vipec is at 8700, and the ski starts missing at 7900-8200rpm. Boost then starts fluctuating between 10-17psi. I disabled the MAP limiter, new plugs gapped at .030. This doesn't happen unless I'm above 70% throttle

    I doubt its the clutch, but who knows. Probably should get in contact with Riva..


  2. #2
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    Could the problem be your bov?

    Sent from my ADR6400L using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. clutch slip torque RIVA Washers ?
    By mrracing in forum 4-Tec Performance
    Replies: 37
    Last Post: 06-20-2007, 10:53 PM
  2. Well victum of Clutch Slipping w/ Les's Washiers..
    By Water4fire in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-11-2006, 10:52 AM
  3. clutch slipping question
    By carlo4tech in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-15-2005, 11:18 AM
  4. Perfect torque wrench for measuring clutch slip moment
    By Green Hulk in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-10-2005, 09:29 AM
  5. Clutch Slip?
    By Tube Master in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-31-2005, 11:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •