2001 RX Carbed. WCM Jet kit. This boat has been set up this way for 3 years and has run perfectly. I winterize and do all the PM.

Current situation. Starts and idles fine in the water. Runs smoothly and pulls hard. It will run at 5k all day. If you Pin the throttle in snaps up to about 6500 and then immediatly falls back to 4850. After a second it feels like you pinned it again and it pulls hard for a second and then falls of again. If you ease it up to 7/8th you can get it to 6k again. Holding it WOT it will hold steady at 4850.
The surging is hard on and hard off. No misses or back fires.

Things I've tried so far.

Fuel system:
Pulled intake tube from tank. Filter is clear, all lines are updated. No grey sludge anywhere.
Fuel filter is new, tried without and condition persists.

Pulled and opened carbs. Internal filters are perfect. Looks like new inside. No corrosion.
Checked return, pulse, and vents. All seems to be functioning correctly.

Tested TPS. Functioning properly. Drops from 5 to .01VDC on Craftsmen meter set to 20VDC
Clipped plug wires.
Checked main ground to block and from mag cover to MPEM.
Disconnected TPS. Jumped TPS.
Disconnected Multi function gauge plug from MPEM.
New plugs with correct Gap. (Rtype)
Checked rear electrical box. Clean and dry.
Switched MPEM.
New Battery.
No messages on Multi Gauge.

Checked RAVE valves, ran with caps and spring off.
Ran with Water regulator cap off. Hot Pipe. Seems to be working. It does seem a little loose on WB.
Replaced coupler from pipe to water box. Hose from WB to exit is in Good condition. No blister or signs of delamination.
Ran it on trailer in the water with seat off. No exhaust leaks.
Last time I started it on the trailer after riding it didn't seem like much water came out of the exhaust.
The only thing I can think of that I haven't done is pull the Water Box and check for an upstruction. Possible but unlikely.

I've been working on SEA-DOOs for years and I've had some weird issues. I'v been working on this one for a month and reading every 951 thread I could find.
So far the TPS seemed the most likely culprit.
I'm at a complete loss. Any help is really appreciated.