Results 1 to 3 of 3
  1. #1

    Lost 300 RPM.....

    Just joking.

    Actually went out today to see the impact of the weather we are having. Best RPM I could get out of the stock RXP today was 7800 RPM, since the air temp is 104, and water temp 95.....


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    funny how the weather plays such a big part on these skis.......

  3. #3
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    Ya no kidding... I was running 8050 this morning and I went out tonight and could only turn 7800

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 113
    Last Post: 05-08-2013, 05:43 AM
  2. RXP new S/C Rebuild....Lost 300 RPMs!!!!!
    By Pirates81 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-10-2008, 05:40 PM
  3. I lost 50 rpm from last year
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-30-2006, 09:08 AM
  4. Wedge installed and lost 50 rpm
    By Kinchyle in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-01-2005, 08:35 PM
  5. lost 400 rpms , could it be weather and humidity ???
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-01-2005, 04:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •