Results 1 to 5 of 5
  1. #1

    waveraider 1100 cdi

    looking for cdi box for 95-96 waveraider 1100
    got one that I repaired a broken wire but didn't fix so I borrowed one from a running ski
    still didn't fix and when I returned cdi to original ski now that one won't start
    looking for any help in troublshooting this problem
    started off with one ski that wouldn't run and now I have 2
    I'm assuming something on ski fried both cdi boxes even though stator specs OK
    anyone who might be of help. please
    I am a 58 year old motorcycle mechanic who is very computer challanged
    know nothing about smiles or icons
    first time posting question

  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Elephant Butte New Mexico
    I assume you have a shop manual and a decent voltmeter.....

    as far as ignitions go a pwc isn't that far off from a motorcycle..but it can get expensive if you miss something obvious. Having a donor ski is a big help.

    The very first thing to suspect on an older Yamaha for a crank but no start is the kill's got two circuits..I run into this on a regular basis..when the lanyard is installed it manipulates two circuits one for the starter system and the other for the ignition system..typically the ignition side fails and the engine will crank..but no power to the cdi to spark it up.

    don't bother trying to fix the switch..the are poorly designed and they simply wear out. the most ou can do for it is to spray some wd-40 under the little rubber boot

    disconnecting the white/black two pin connector coming from the handle bars should remove the issue and allow the engine to start..but you won't be able to shut it down without reconnecting have the water hooked up and ready to go.

    the wiring diagram is a bit misleading..the donor ski may have the same kill switch problem

    no computer skills needed for this issue..just a methodical troubleshooting plan.

    a replacement switch can be a wallet flattening don't be surprised at the cost. Those things are brutal expensive and I would suggest a new the used ones out there could be a few moments from providing the same hair pulling tooth grinding affair.

  3. #3
    lukejaeger1's Avatar
    Join Date
    Jul 2011
    I've got a cdi and a stop/start switch for a raider 1100 if you want to give them a try. Send me a pm or post something if your interested. I don't know for sure if they work but I'd be willing to send them your way.

  4. #4
    definately interested in those parts to give them a try

  5. #5
    That kind of sounds like my problem. I replaced my CDI from a ski that did fire, and on this ski, I still don't get any fire. I recall checking the stop/start switch, but I might have checked it wrong with a multimeter. How could I get it to stop if I started the ski with it unplugged?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts