Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    2005 GTX S/C starter question. Push starter button, clicks.

    Have an '05 185 GTX. Brand new battery and fully charged. When I go to start the ski, many times when you push the starter button it just clicks. It has always started but sometimes it takes many pushes of the starter button for it to fire. Ski only has 51 hours on it and is a freshwater ski. It works perfectly in every other way. Would like to get this resolved. Also it seems as if the starter turns over slowly.

    Any suggestions on where to start?

    Thanks in advance...


  2. #2
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Sounds like the starter solenoid is going. Search around, it's a common problem on the early year skis. You can jump the terminals of the solenoid with a screwdriver and it should turn over. Or you battery is weak or dead.

  3. #3

  4. #4
    R-Doo's Avatar
    Join Date
    Sep 2006
    Location
    Minnesota
    Posts
    833
    +1
    77
    I had the same problem on my 06 RXT. Replaced the relay and all's well now.
    Mine did it for a full season before I swapped it. Took it apart and you could see the contacts weren't working properly.

  5. #5
    Thanks for the replies. I think I will start with the relay and work from there. Where is the relay physically located inside my ski? Is it easy to get to?

    Again, thanks much!!!

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Follow the power wire from the battery and it will lead you to it.
    It's usually by the fuse box.
    2 bolts and POP it out.
    Very easy fix.

  7. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    40-45$ at a stealership for the relay.

  8. #8
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Right here....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mpem.jpg 
Views:	79 
Size:	81.4 KB 
ID:	276613  

  9. #9
    Booner76's Avatar
    Join Date
    Oct 2009
    Location
    Stirling ,Ont.
    Posts
    222
    +1
    5
    Changed one on a friends ski .. good to go......

  10. #10
    Thanks much. Will order & replace!!!!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 GTX Fuel Pump Failed Question
    By O'side GTX in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-28-2014, 02:57 AM
  2. 1996 gtx 787...no starter when start button is pushed???
    By kaotic1 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-27-2014, 10:22 AM
  3. Boost question for a 2005 GTX Limited 215
    By Devildog9999 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 12-20-2011, 08:26 PM
  4. need starter button 97 gtx
    By Euro Scott in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 04-14-2009, 08:58 PM
  5. 2005 GTX question
    By mhagen in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-30-2008, 10:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •