Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Join Date
    Jul 2011
    Location
    Medford, NJ
    Posts
    20

    2005 Stx 12F NEED HELP

    I have been trolling this forum for about a year nowgaining a lot of information in regards to my two stx 15fs. I want to thank allof you for the amount of information you are passing on to everyone.

    Now I need to ask for help on another ski. My daughter just purchased a 2005STX 12f with 46 hours on it. When she bought it the previous owner just had thepump replaced. In fact she picked it up from the repair shop. My son-in-lawsays he heard it run at the repair shop before he purchased and it ran good.

    When she got it home we found that it is idling rough and if you advance thethrottle it would bog down. If you get it to run up in RPM it would go to about4,000 then jump up dramatically to 7,000 rpm.

    We checked the injectors and it appeared that 1 and 4 would intermittentlywork. We tried injectors from a 15f and it did not improve. We tried the coilsand there is no difference. We tried an ecu from a 15f and it seemed to getmuch better and would accelerate without bogging down. We got a replacement ecufor 12f and now it is back to the same thing. It will idle rough and then onceyou get it up to a certain rpm it jumps way up.

    We are at the point of not knowing what else to check.Any ideas would be appreciated.


  2. #2
    Check the compression on your 12F.
    With a calibrated gauge at sea level, it should reach 225+ psi.
    The more important thing is that all 4 cyls should give very similar numbers within +/- 10 psi from each other.
    Report back what you find.

  3. #3

    Join Date
    Jul 2011
    Location
    Medford, NJ
    Posts
    20
    Quote Originally Posted by meangreenman View Post
    Check the compression on your 12F.
    With a calibrated gauge at sea level, it should reach 225+ psi.
    The more important thing is that all 4 cyls should give very similar numbers within +/- 10 psi from each other.
    Report back what you find.
    Thank you for the reply. I will do this in the morning and post the info.
    We have a service manual so we will be researching tonight, but in the meantime do you know if there is a common connection between injector 1 and 4. Both of those do not open while 2 and 3 do. We have already tried the coils but no fix.

    Thanks again

  4. #4
    The only connection is that ECU sends a signal to one Coil and it fires up both #1 & #4 plugs.

    #1 & #4 pistons reach the TDC at the same time.
    #1 & #4 cyls get hotter than the other two.

    It's rare on 12F (or any other 4-stroke Kawis) that ECU fails but...

  5. #5

    Join Date
    Jul 2011
    Location
    Medford, NJ
    Posts
    20
    Week here is the update.

    Compression:
    #1- 180psi
    #2- 200psi
    #3- 195psi
    #4- 210psi

    I am going to assume that the compression difference is going to be the problem. Entire top end build? If so how much, approx we looking at?

    Thanks again.

  6. #6

    Join Date
    Jul 2011
    Location
    Medford, NJ
    Posts
    20
    Quote Originally Posted by meangreenman View Post
    The only connection is that ECU sends a signal to one Coil and it fires up both #1 & #4 plugs.

    #1 & #4 pistons reach the TDC at the same time.
    #1 & #4 cyls get hotter than the other two.

    It's rare on 12F (or any other 4-stroke Kawis) that ECU fails but...
    I did some more reading about similar problems with injectirs and tried a gas soaked rag in the intake as someone else had tried. When I did that the engine idle smoothly and accelerated up through the range of rpms. I took the rag off and the rough idle returned and no acceleration. Injectors #1 and #4 are intermittent.

    Does the cam shaft sensor tell the ecu when to fire the injectors and if it does it there a contact point on the shaft that could not picking up all of the time. I may be stretching it here but I feel we are close to fixing this.

    Thanks again.

  7. #7

    Join Date
    Jul 2011
    Location
    Medford, NJ
    Posts
    20
    UPDATE - After checking all of the sensors, wires, coils, injectors etc we have determined that we are not getting enough pressure on the fuel line. The pump is putting out enough pressure and flow, but there is no restriction back to the tank to build up the pressure. It appears that the flow restrictor in the fuel pump unit is not funtioning properly.

    Is there any alternative besides buying a new/used pump unit to get this restriction?

    Thanks again for the information.

  8. #8
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    Cut the return line and install an adjustable one. Any automotive one can be made to fit. I am using a fuelab regulator. Pull the fuel pump and check to see if the factory regulator is in the tank.

    Sean

  9. #9

    Join Date
    Jul 2011
    Location
    Medford, NJ
    Posts
    20
    Thank you for the information smokesevin.

    We are going to try to find an adjustable fuel regulator locally so we can get on the water this weekend.

    The factory regulator is on the fuel pump housing but does not appear to be working.

  10. #10
    If the fuel pressure is not regulated, why only #1 and #4 injectors are acting up?
    Also, how did you determine that the pressure regulator is located inside the fuel pump housing?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need 2005 STX 12F Head Gasket Kit (+intake/exhaust)
    By theswits in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 09-21-2011, 04:30 PM
  2. Need motor for 2005 STX 12F
    By brokestx12f in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 07-22-2009, 09:12 PM
  3. Newb needs info on stx-12f please help!
    By Fulltitl429 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-09-2009, 11:29 AM
  4. 2005 STX 12f....no fuel
    By x2dad in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-03-2007, 02:33 PM
  5. 99 stx 900 Need help with engine!!! HELP!!!!
    By gvnitup in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 07-11-2007, 04:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •