Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2012
    Location
    st. paul , MN
    Posts
    2

    polaris sl780 spark issue

    i have a 96 sl780 that has was running great, died and now only has spark on 2 out of three cylinders. the mag and center cylinder are good , the pto cylinder has no spark,,, any ideas would be greatly apperciated


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Welcome to The Hulk!

    The ignition on that ski fires all cylinders at once. There are 3 separate coils in the electrical box all wired in series. So, It cold be a bad secondary winding on the coil for the PTO, bad wire, bad boot, or defective spark plug.

    Start simple and swap spark plugs and see if the problem moves. If it does not, remove the boot and cut the wire back 1/4" and re-install the boot. If that does not help, grab a manual and start doing ignition tests on the resistor boot and wire/coil.

    http://polarispwcknowledge.shorturl.com/

  3. +1 by:


  4. #3

    Join Date
    Jul 2012
    Location
    st. paul , MN
    Posts
    2
    thanks. ill try it all, ive already switched plugs hoping for simple fix!

  5. #4
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Quote Originally Posted by greg1294 View Post
    thanks. ill try it all, ive already switched plugs hoping for simple fix!
    I attached a wiring diagram below. At the top are the resistance measurements you can use to test the coils and wires.

    Click image for larger version. 

Name:	96SLT780.jpg 
Views:	2018 
Size:	98.2 KB 
ID:	276744

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris sl650 spark issues now!
    By Kevman in forum Polaris Projects
    Replies: 11
    Last Post: 07-26-2016, 06:10 AM
  2. Replies: 7
    Last Post: 09-01-2011, 03:35 PM
  3. 94 Polaris SL 650 Spark issue
    By james5 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-04-2011, 01:45 PM
  4. 1994 Polaris SL 650 Spark issue
    By james5 in forum Open Discussion
    Replies: 0
    Last Post: 07-03-2011, 11:31 AM
  5. polaris x 45 spark issues
    By worldwind in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-06-2011, 10:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •