Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2012
    Location
    Houston, Texas, United States
    Posts
    3

    2010 Yamaha VX110 - HELP!!!

    We have a jetski rental business and 3 of our 2010 Yamaha VX110 are experiencing lack of power when throttled - We do run them in saltwater and also experience at times sand berms and oyster shells - There is some white smoke coming out from 2 of the 3(oil/gas mix???) and one of them has a clinging rattling noise that perhaps a sea shell may have gone in via the intake and damaged the impeller - All 3 skis start and idle but will not go over couple of mph - What should we do or check for and how difficult is to replace the impeller or fix it - what other things should we look for for instance fuel lines, etc - Will perform compression test on them as well - Any and all help is highly appreciated.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Sounds like your prop is dinged up and the wear ring is probably trashed.
    Search in the forums for prop and pump removal.
    It's not that hard with common tools and ur going to need to know for the rest of ur rentals.
    Your 2 that are smoking might be getting hotter with lack of water thru the pumps to cool them.
    Or there is sand in the cooling system and not allowing full circulation of the cooling water.
    I would check the cooling on any ski that has run aground in sand.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I've seen those rentals at 2600 hours.
    Beat to shit.
    But still running with proper services and a good tech.

  4. #4

    Join Date
    Jul 2012
    Location
    Houston, Texas, United States
    Posts
    3
    Quote Originally Posted by wotxxxsd View Post
    Sounds like your prop is dinged up and the wear ring is probably trashed.
    Search in the forums for prop and pump removal.
    It's not that hard with common tools and ur going to need to know for the rest of ur rentals.
    Your 2 that are smoking might be getting hotter with lack of water thru the pumps to cool them.
    Or there is sand in the cooling system and not allowing full circulation of the cooling water.
    I would check the cooling on any ski that has run aground in sand.
    I cant find a forum for a yamaha prop and pump removal - can someone please paste a link - thanks a lot guys

  5. #5

    Join Date
    Jul 2012
    Location
    Houston, Texas, United States
    Posts
    3
    How do I check the cooling system? The lack of water to the pumps is because of what? is because the impeller is broken?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha VX110 40hrs prop hitting housing?? Please help
    By RF1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 06-01-2014, 10:33 PM
  2. FS 2005-2010 yamaha vx110 throttle body assembly
    By T-DUB in forum Yamaha Classifieds
    Replies: 3
    Last Post: 10-12-2013, 12:40 PM
  3. Yamaha VX110 Engine Removal
    By msarge in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 07-22-2011, 09:49 AM
  4. HELP: Yamaha VX110 Won't Run Right
    By bahama in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 12-19-2008, 06:22 PM
  5. Good price for Yamaha VX110 Deluxe?
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 01-22-2008, 05:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •