Results 1 to 5 of 5
  1. #1

    Polaris SL 750 MFD trouble

    Ok, My 94 polaris sl 750 round MFD was working great yesterday. Then of course, I pop a fuse... Nothing new here. I replace the fuse and it keeps popping as soon as I put it in. The fuse pops on about 7 different trys. Finally I let it sit for about two hours and I try another fuse and it works. The MFD lights up but now on the screen it only shows " 8. " thats it. the mode button will not do anything nor will the set button. I cant scroll through the options, it will not show gas or oil etc. Just 8. I tried taking out the fuse again and put it back in with the same results. any help?


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Only need to post in one section.......

  3. #3
    Great, thanks for the help putz.....

  4. #4
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Quote Originally Posted by pdarling20 View Post
    Great, thanks for the help putz.....
    I have a feeling a response like that will not inspire others to help. May not want to bite the hand that feeds.

    I would try a MFD reset. Instructions ca be found here: http://polarispwcknowledge.shorturl.com/ If that does not resolve the issue (and based on your description, it likely will not) you will need to replace the MFD. Sounds like an internal issue, maybe water intrusion.

    BFC is correct, it is generally frowned upon to post in multiple areas. It just clutters the forums and creates issues. You may not have known.

  5. #5
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by pdarling20 View Post
    Great, thanks for the help putz.....
    Good luck in your future endeavors....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB WTB 95 polaris sl 750 mfd
    By 95gtx205 in forum Polaris Classifieds
    Replies: 5
    Last Post: 10-10-2014, 12:30 PM
  2. Polaris SL 750 rpm troubles
    By pdarling20 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 04-29-2013, 10:50 PM
  3. WTB 94 polaris sl 750 mfd. i want to buy a mfd and cdi box
    By srt8charger in forum Polaris Classifieds
    Replies: 8
    Last Post: 06-24-2012, 02:11 PM
  4. 94 Polaris SL 750 MFD not working... Any tips?
    By pdarling20 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-11-2012, 10:38 AM
  5. 1994 Polaris SL 750 problem
    By Playtime in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-24-2007, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •