Results 1 to 9 of 9
  1. #1

    Join Date
    Apr 2011
    Location
    Tripoli, Iowa, United States
    Posts
    13

    '02 Virage TXi 1200 Full Throttle Problem

    It starts right up and runs great up to 3/4 throttle. When you give it more gas after 3/4 it doesn't have anymore power and it feels as if it looses a little power...Any suggestions on how to get it to full throttle with more power?


  2. #2
    Have you checked your fuel pressure? If it isnt 20 lbs plus you could have a pressure regulator failure. You could also have a throttle position sensor failure.

  3. #3

    Join Date
    Apr 2011
    Location
    Tripoli, Iowa, United States
    Posts
    13
    would the throttle position sensor also cause the shifter to not shift? Daughter said she got it to shift to Nuetral and Reverse once or is that a lubrication problem?

  4. #4
    Not sure how the mechanism works on the 02 TXI. My 01 the reverse is electric and I dont bother with using it, more of a pain than it is worth because ever time I use it the rpm limiter gets stuck at 3000 rpm and I have to shut off ski and then restart it. If yours is mechanical then it should have nothing to do with what you are describing as a 3/4 throttle problem, unless it is sticking on the rev limiter at 3000 rpm.

  5. #5

    Join Date
    Apr 2011
    Location
    Tripoli, Iowa, United States
    Posts
    13
    '02 has a lever on the left side with F N R .....I will have to check it out better monday morning.....

  6. #6
    Its not really a "shifter". The impeller always turns the same direction and is linked directly to the engine crankshaft. All it does is drop a bucket over the pump output nozzle and redirects the water flow forward.

  7. #7

    Join Date
    Apr 2011
    Location
    Tripoli, Iowa, United States
    Posts
    13
    Thanx for your help Comp

  8. #8
    My money would be on the TPS.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    Quote Originally Posted by sledheads4 View Post
    would the throttle position sensor also cause the shifter to not shift? Daughter said she got it to shift to Nuetral and Reverse once or is that a lubrication problem?
    See my signature links.

    Binding in the Reverse Lever mechanism is common and is repairable.

    TPS failure can cause all sorts of strange symptoms. The only real test is to install another known good or new TPS.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 02 Virage Txi 1200 DI engine parts (short block)
    By Bigbill55 in forum Polaris Classifieds
    Replies: 2
    Last Post: 05-17-2015, 11:33 PM
  2. help! starting problem 02 virage txi
    By jhutson in forum Polaris Tech Tips and Info
    Replies: 1
    Last Post: 07-08-2013, 08:28 AM
  3. Virage TXI 1200 starting problems
    By maetubson in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-21-2010, 01:56 PM
  4. Need Help on '02 Virage TXi Starting Problem
    By bluedevil60 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-26-2009, 12:06 PM
  5. 02 Virage TXi Backfire
    By sammer77 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-07-2007, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •