Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    94 SL 750 full throttle problems

    i have a 94 SL 750 with an Ocean Pro ride plate and a Hot Seat Exhaust. My problem is in the water the ski will not get over 3000 rpm's but out of the water the ski acts like it should. i have bypassed the fuel selector switch and the water seperator, changed the fuel pump, cleaned the carbs and still no change. It has 105 psi on all 3 cylinders.


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Welcome to the Hulk! What did you change the fuel pump out with? What are your carb screws set at? May help to reset the screws to factory.... never know what may have happened over time.

    Check out all the fuel system upgrades here. http://polarispwcknowledge.shorturl.com/ It is highly recommended to rebuild the carbs with genuine Mikuni kits as well...

  3. #3
    i replaced the fuel pump with the one i had from my other ski the exact exact same year and model. i have a mikuni triple outlet fuel pump upgrade kit on the way. but with the intake cover and the screen off i can see the high and the low jets putting out fuel but ive only seen that out of the water where the ski acts fine i havent checked it when its in the water(where all my problems are happening) I havent done anything to the carb ajustments yet because ive used the ski for about 3 months and not had any problems. it started doing this about 20 mins after i put in at the lake right after i put the ocean pro ride plate on, which i dont know if that make any difference or not.

  4. #4
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Ride plate wont make a difference. The jetski is under alot more load in the water, which is why you dont experence the problem in the water. Let us know how you make out with the new fuel pump.

  5. #5
    can anyone tell me the factory carb settings for my 94 750 SL?

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Get yourself a good manual. Highs 1 1/4M 3/8C 7/8P Lows 1/2 When did you last check compression?

  7. #7
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    So does the ski run fine for about 20 minutes then wont go above 3000 rpm? 105 psi is low compression and I would rebuild the top end for sure, but that shouldn't stop the ski from getting its full rpm range

  8. #8
    i last checked the compression a couple days ago when all this started with the rpms not going past 3000 rpm's.

  9. #9
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by josh843 View Post
    i last checked the compression a couple days ago when all this started with the rpms not going past 3000 rpm's.
    You don't mention if you verified good spark on all three cylinders. Sounds like you dropped a cylinder....? Maybe try cutting the plug wires back 1/4" and re-installing the boots?

  10. #10
    yea, ive already done that, no difference tho. My triple pump came in so im in the middle of installing it, hopimg it will take care of this prob

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 sl 750 fuel problem?
    By pent250 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 08-27-2010, 06:36 PM
  2. 94' SL 750 Carb problem
    By quad2water in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-21-2008, 11:37 PM
  3. 94 SL 750 Ignition / Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-23-2007, 09:59 PM
  4. 94 SL 750-Trim problem
    By nbpolaris in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-31-2007, 01:56 PM
  5. '94 SL 750 Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-24-2007, 07:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •