Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2012 RXP take off

    I managed to put on couple hours on my 2012 RXP last week so the odometer now reads 2 hours . my Friend who has a 2005 Yamaha 155 horses counts to three and we both take off and for me there is lag on take off so he beats the crap out of me until we reach 25MPH and then gets smoked.

    Whats the deal with the lag on takeoff? Engine protection limiter? Will this go aways after the 10 hr?Hope this is temperorily

    Also, when I told the dealer about the ski tilting to the left on slow speed he says its the amount of torque this ski has and no need to adjust the steering? Is he full of it?

    Thanks guys.


  2. #2
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by happy_ka View Post
    I managed to put on couple hours on my 2012 RXP last week so the odometer now reads 2 hours . my Friend who has a 2005 Yamaha 155 horses counts to three and we both take off and for me there is lag on take off so he beats the crap out of me until we reach 25MPH and then gets smoked.

    Whats the deal with the lag on takeoff? Engine protection limiter? Will this go aways after the 10 hr?Hope this is temperorily

    Also, when I told the dealer about the ski tilting to the left on slow spead he says its the amount of torque this ski has and no need to adjust the steering? Is he full of it?

    Thanks guys.
    Thats funny... I know what your talking about.. But lets just clarify the ski isnt pulling to the left correct... The back end feels like it tilts to the left correct? If so its normal.I think it has something to do with the hull design.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Wait till after 5hrs then make sure your ski is in sport mode, then race him again,

  4. #4
    superman's Avatar
    Join Date
    May 2007
    Location
    Sunrise, FL
    Posts
    175
    +1
    1
    Sounds like your not in Sports Mode. Also make sure the VTS is set in middle or below during launch.
    That way you don't jump out of the water and loose your traction. Like Troy said, after 5 hours you will notice an increase in power.
    Mine ski does lean and rock and forth at low speeds due to the hull design. After getting on a plain it will straighten out. My ski pulled to the right at high speeds so I had to get that adjusted.

  5. #5
    OK thx Guys, Sport mode , VTS in middle and 5 hrs is good to know.

  6. #6

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Make sure your in sport mode (I assume you already know this). These 2012 RXP's "crab" or lean at slow speed. Hull design, Deep v and spoon shaped sides are the root cause. Mine does the same. They jump up on plane fast and handle well.....

  7. #7
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    899
    +1
    70
    You are not in sport mode! This ski blows every other ski off the start!

  8. #8
    Bounty Hunter Carlos Thomas's Avatar
    Join Date
    Jul 2007
    Location
    San Leandro, CA
    Posts
    1,401
    +1
    22
    I tried ECO Mode for about 20 seconds. Normal mode for 40 seconds. Then 6 hours and 59 minutes in Sport Mode. I cannot do anything other than Sport Mode.

  9. #9
    I am Newbie to Jetski's, thats why From now on it will only be on sport mode. Awesome site, I knew you guys had the answer. The mechanic said wait until 10 hrs until it will break loose but I am pretty sure its the Sport mode as you indicated. Thanks again

    Will let you guys know the result next Saturday when my friend and I are getting on the Lake again to see how the two skiis do, LOL.

  10. #10
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    No, its not all about the sport mode...Like several here have said, the ski will open up more power around the 4 hour and then the 7 hour mark..By 10 hours your full power and RPM

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rxp x hesitating from take off
    By ski33 in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-29-2012, 04:16 AM
  2. 05 rxp no take off speed
    By RXP2 in forum 4-Tec Performance
    Replies: 4
    Last Post: 02-01-2010, 04:26 AM
  3. seadoo rxp sluggish when taking off, sc? or impeller ?
    By linuxglobal in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-19-2009, 03:47 PM
  4. rxp-x and rxt-x take off PICS!!
    By ando in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-29-2008, 02:27 PM
  5. 2004 rxp Rough take off
    By Hoovermaneuver in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-06-2007, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •