Results 1 to 4 of 4
  1. #1

    Join Date
    Nov 2005
    Location
    Brighton,mich.
    Posts
    78
    +1
    1

    97 gp1200 speedo goofy?

    My factory speedo on my 97 gp1200 has started acting wierd. I reads fine up to about 35mph and then the faster you go the slower it reads.I checked the little wheel and see no weeds or anything else.It seems to spin freely and smoothly.Any ideas? I haven,t made any ride plate changes or anything else underneath.


  2. #2
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    They tend to do that eventually. They just wear out and don't work well. Mine reads 10mph tops now which is way worse then last year. It seems like it spins ok but occasionally when I try to spin it it wobbles instead of spinning nicely. I figure thats why it doesn't work. It has a slight wobble.
    You could try lubing it up with wd40 or something before you go out and see if it works better. but in the end, you'll most likely need a new sensor or just do what everyone else does and ignore it and ride on.

  3. #3

    Join Date
    Sep 2008
    Location
    Clarksburg, WV
    Posts
    609
    +1
    1
    Get a small gps. I picked up an older garmin 201 wristwatch for cheap. It has a big enough display to see we doing speed runs and it can mount on the handle bars with the stock handle bar cover removed or with after market bars.
    My ski didn't have a speedo when I bought it so I got one on eBay and it never read over 10 , so i toon it of an filled i the hole in my plate. My brothers two GPs both read about 75 at 60mph. I dont know how the newer skis are but these wheels don't seem very good. Granted some GPs are 15 year old machines and that little plastic wheel is bound to wear out spinning so fast.

  4. #4

    Join Date
    Nov 2005
    Location
    Brighton,mich.
    Posts
    78
    +1
    1
    I have a hand held GPS so I know how fast the ski is, it just buggs me that the factory speedo doesn't work.I thought it might be an easy fix.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The history of my 97 GP1200 (long, possibly boring to some)
    By 97GPSLEEPER in forum Yamaha Old School Skis
    Replies: 15
    Last Post: 10-09-2008, 01:29 PM
  2. What mods should I do to my stock 97 GP1200..
    By 2lick in forum Yamaha Open Discussion
    Replies: 7
    Last Post: 02-11-2007, 08:28 PM
  3. My 97 Gp1200
    By 97GPSLEEPER in forum Videos & Pictures
    Replies: 10
    Last Post: 07-25-2006, 08:45 PM
  4. 97 Gp1200 hull crack's?
    By jy in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-09-2006, 11:50 AM
  5. I wanna run dual cooling on my 97 GP1200
    By SLOW65U in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 12-14-2005, 01:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •