Results 1 to 3 of 3
  1. #1

    Join Date
    Aug 2009
    Location
    San Diego, CA
    Posts
    71

    Just Wanna Know Why. (No oil)

    Well I lost compression in the #3 cylinder in my SUV. This was the only ski I did not go to premix. Finally I know what everyone was crying about that didn't premix. Honestly I just kept putting it off. LESSON LEARNED!
    Everything looked fine, oil line was in place and clear and no leaks. Oil just wasn't getting to the #3. Spark plugs 1 & 2 had oil on them but 3 was dry. Why would oil not be reaching only that cylinder. From reading other posts the third cylinder seems to be the phantom. WHY?


  2. #2

    Join Date
    Feb 2010
    Location
    Port Lambton, Ontario
    Posts
    44
    Carb plugged up....rear seal leak

  3. #3
    I have also heard those little plastic valve/couplers that are inline on the oil lines going to the carb fail.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyone knows why the rxp for 2011 have no change?? thanks
    By esteban3417 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 09-16-2010, 08:31 AM
  2. anyone knows why the rxp for 2011 have no change?? thanks
    By esteban3417 in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-13-2010, 08:11 AM
  3. Just bought sl 900 no spark
    By slxcrazy in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 03-20-2007, 08:48 PM
  4. Why No Alcohol?
    By rossnemo in forum 4-Tec Performance
    Replies: 18
    Last Post: 12-05-2006, 10:53 AM
  5. Why no 3 bearing mod with riva-skat 3 blade 15/19
    By excess in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-23-2006, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •