Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    rosey's Avatar
    Join Date
    Jul 2012
    Location
    Houston, TX
    Posts
    71
    +1
    2

    dismantled the pump on rosey the red rocket 2012 vxr

    Click image for larger version. 

Name:	IMG_1430.jpg 
Views:	105 
Size:	90.9 KB 
ID:	276838Click image for larger version. 

Name:	IMG_1427.jpg 
Views:	117 
Size:	116.6 KB 
ID:	276839all dismantled after just 13 hours of rideing. dang sand bars with big rocks...
    ouch that is a bent impeller and marred duct housing.
    thanks for all the information on how to dismantel the pump.


  2. #2
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,382
    +1
    165
    Impros is pretty good at fixing stuff like that......my props were bent like hell and they came back absolutely perfect for 75 bucks.......hope this helps

  3. +1 by:


  4. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,591
    +1
    4,798
    OUCH, hope you get it sorted out.

  5. #4
    rosey's Avatar
    Join Date
    Jul 2012
    Location
    Houston, TX
    Posts
    71
    +1
    2
    i plan to order the Solas prop for it in the morning. Should I order a new impeller duct and impeller housing? The leading edge of a couple of the veins on the duch are banged up a little (as you can see in the pic). The impeller housing has a few nicks in it. I thought about just using some JBweld to smooth them out. I am not racing it so a 1 mile an hour difference is not that much in my book... for now anyway.
    Thanks for the Impros advise. I will be sending the origional prop to either SBT or Impros (i can't seem to get a responce from impros though) to have them work it over so I have a back up prop for the next time a rock or stick finds its way into the pump.
    Cheers from Houston

  6. #5
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    i would try blending the what you have vs. applying J-B weld. def check for cracks thoroughly ! good luck.... email impros you will get a response for the prop work.

  7. +1 by:


  8. #6
    rosey's Avatar
    Join Date
    Jul 2012
    Location
    Houston, TX
    Posts
    71
    +1
    2
    Thanks. I didn't even think to look for cracks. Better do that tonight so I can order parts tomorrow if needed.

  9. #7
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    what the hell did you use the 3# sledge on and the wonder bar for?

  10. #8
    rosey's Avatar
    Join Date
    Jul 2012
    Location
    Houston, TX
    Posts
    71
    +1
    2
    Nuthing yet. It was just in case. I just dove into the dismanteling of it with no experience. I figured sometimes a bigger hammer is needed. hahaha

  11. #9
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    you can put that away !!! a 1/4 drive metric set with a long extension and a couple screw drivers is pretty much it....... as for torque i am certian they have specs but tight and not broken is a great start! apply loctite unless you plan on doing some prop swapping in the near future. as with anything, if you have touched it with a wrench after rides check it again just to be safe. (or if its a shovelhead-some of you will get this)

  12. #10
    rosey's Avatar
    Join Date
    Jul 2012
    Location
    Houston, TX
    Posts
    71
    +1
    2
    Btw. I used a screwdriver on the pry tabs and a 5 in 1 tool (painters tool like a thick putty knife) hammered in the gasket seam to break the gasket material. it came right off that way.. What is that gasket material anyway, off the shelf silicone? I need to get some of that.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. re doing the jet pumps on a 2000 challenger
    By Joe Stang in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 01-18-2009, 09:02 PM
  2. what oil goes in the jet pump on a 06 rxp?
    By skidoo76 in forum 4-Tec Performance
    Replies: 11
    Last Post: 12-05-2008, 08:49 AM
  3. putting a RXP pump on the 4tec XPL
    By rapidacceleration in forum 4-Tec Performance
    Replies: 21
    Last Post: 10-06-2006, 06:22 AM
  4. My first ride on the red bull
    By The Bandit in forum 4-Tec Performance
    Replies: 21
    Last Post: 08-08-2006, 11:48 AM
  5. Why disconnect and remove the Accel. Pump on the GPR?
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-16-2006, 12:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •