Results 1 to 5 of 5
  1. #1

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111

    1996 polaris 900 replaced lr 23 module now it wont fore on front cyl.

    At least I thought I had a 1996 but the electric box doesnt have a lr54 so I am assuming it is a 1997? I had to replace my lr23 as the bilge would stay on but now I have no power to the front cylinder. The plug wire has good conductivity but the coil block is one unit for the three cylinders. Do I just have to replace the coil block or am I missing something?


  2. #2

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111
    is the ignition coil pvl 105553.03 and the cdi 4060137 original or upgrade?

  3. #3
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Answer can be found here: http://polarispwcknowledge.shorturl.com

  4. #4

    Join Date
    Oct 2009
    Location
    Pouce Coupe BC
    Posts
    111
    Wow the dealer here wants $520 for the update kit
    3-5 days delivery....

  5. #5
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    If they still stock them, you can get an update kit for about $320+ shipping online form several places.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 polaris 900
    By turbogn in forum Polaris Tech Tips and Info
    Replies: 9
    Last Post: 06-14-2013, 05:22 PM
  2. Replaced Fuel Filter Now It Wont Start 20$ through paypal leading to fix
    By chuckcanavi in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 08-30-2011, 12:03 AM
  3. took gpr apart and now it wont start!
    By richdash in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 08-06-2010, 07:06 PM
  4. RXP 06 died while running now it wont start
    By Kl0n in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-16-2010, 03:54 PM
  5. Changed my oil filter, now it wont start!!!
    By gorey in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-27-2009, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •