Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Help

  1. #1

    Join Date
    May 2012
    Location
    Coopersburg, Pennsylvania, United States
    Posts
    33

    Help

    So we just got some stuff done to our 2004 rxp and well the guy completely screwed us he was just supposed to do the steering cable and a bit of other simple things well he supposedly did and said it was good to go after we told him it was going in saltwater well now there's missing gaskets and such ever were so now there's saltwater in the oil and ever were else the thing basically doesn't turn over like if the motor is locked it takes many tries to start if it does so we think tha the motor is toast again saltwater in the oil and also what would the next step work wise be?


  2. #2

    Join Date
    May 2012
    Location
    Coopersburg, Pennsylvania, United States
    Posts
    33
    Also the ski seamed to have a huge loss of power and response right as it gets to 6000 rpm it could cut out and it took longer then it should have to get to that rpm so there might be a loss of compression. And we just got around to looking at our other ski a 2000 xp 951 and the air box is completely off the carbs so that probably has water in it too this guy completely screwed us. I will not mention the name quite yet because we haven't talked to him yet

  3. #3
    nsschwenk's Avatar
    Join Date
    Jun 2012
    Location
    Evansville, IN
    Posts
    88
    +1
    1
    Wow! I would be getting a lawyer! Ever seen a video of how they destroy a "cash for clunker" car? I think he just did that to your engine by not doing it right. Did he work at a dealer?

  4. #4

    Join Date
    Nov 2007
    Location
    Branson, MO area
    Posts
    190
    +1
    1
    What did he do that would allow salt water into the block? Are you open loop colling? Blown head gasket could allow antifreeze into the block but not salt water unless its open loop. Was it towed without pinching off the hose with the red stripe?

  5. #5

    Join Date
    May 2012
    Location
    Coopersburg, Pennsylvania, United States
    Posts
    33
    I have no idea what he did but it's closed loop and he has his own company he screwed both machines though this one just has more extensive damage I am sure it's salt water because of the smell though and the antifreeze level a hasn't moved. There is also a missing gasket on the jetpump were water is squirting out like crazy. A few missing screws etc etc on the xp he didn't finish routing any of the hoses or cables and he left the air box off the carbs so I don't doubt that there's salt water in the engine there too but that is much more salvageable if this guy doesn't pay to fix it then we sure as hell are getting a lawer he said we were good to go even after we told him we were going to be putting them in salt water. I guess we should have thought twice when the trailer fenders he welded fell off and the lights he put on the trailer shorted so now our trailer doesn't have brake lights and such just two red lights for a long as trip home.

  6. #6

    Join Date
    May 2012
    Location
    Coopersburg, Pennsylvania, United States
    Posts
    33
    Little update the guy said he will try to take care of it and I don't. Know why but I seemed to have left out that ther was a leak somewhere tin the impeller housing were when it's flushed out it sprays water upwards were it shouldn't be I kinda think he missed a gasket or something. We also figured out that the xp is ok as the filter did not come off till after it was flushed out when we started the other one because of the way the rims were when we ran it to dry it out. It spiked to 4000 rpm with a bit of a hanging so we think that's when it came of Or hope it has started and ran fine since.

    When it's fixed I would like to do some cheap mods so I want to know what there is? I have herd of the reverse bucket mod what is it? What other mods can you recommend? Same with the xp though I will ask that in the right place

  7. #7

    Join Date
    May 2012
    Location
    Coopersburg, Pennsylvania, United States
    Posts
    33
    So the guy said that he fixed it and they are ready to pick up he said that it was the little boot on the vts and it was his fault he didn't replace it the first time he said he changed the oil out multiple times and such but how does the vts boo allow oil into the motor?

  8. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Water came in thru your air intake or your exhaust valves.
    Water had to get pretty high inside the hull to get water in the oil.

    After multiple oil changes ride in for a couple hours to burn off the left over water residue in the oil.

  9. #9
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    The motor life has been severely shortened.
    Once that ski sits for any length of time its going to internally RUST.

    Timing chain , valves, EVERYTHING!!!

  10. #10

    Join Date
    May 2012
    Location
    Coopersburg, Pennsylvania, United States
    Posts
    33
    What would the best way to combat this ? He said he changed the oil multiple times to clean out as much of the water as possible.

    The other thing is that when you put the key on you get the normal beeps but when you try to start it it turns over once maybe but then you get 1 long beep he said its the battery and he is going to replace it for free since he put it in last week. But does that sound like what it is?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  2. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  3. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •