Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Angry Brand New 2010 FX SHO topping out at 10mph after 10 hour break in period

    I just purchased a 2010 Yamaha FX SHO Waverunner from I-90 Motorsports out of Issaquah, WA. Not happy.

    Followed dealer and manual instruction on break-in, took for a ride right around the 10 hour period and the engine started vibrating really loud. Pulled it back in and checked the impeller, nothing. Pulled it up onto the trailer, got underneath the craft and checked the impeller, nothing. Put it back in the water, sat at the dock and ran it at 5mph, fine; revved to 10mph and it does not go any faster. Engine was not locked, it was it regular running mode.

    Anyone had this issue? The dealer says the engine is bulletproof.........I'm begging to differ. I spent a crap ton of money on this hunk of metal because I researched the hell out of it and it said it was RELIABLE. If someone knows what the heck is up with my engine, I'd be stoked to hear.


  2. #2
    Carbonic's Avatar
    Join Date
    Sep 2011
    Location
    Omaha, Nebraska
    Posts
    448
    +1
    32
    How do the plugs look?

  3. #3

    Join Date
    Sep 2011
    Location
    West Des Moines, Iowa
    Posts
    206
    +1
    7
    Under warranty if new. Its the dealers problem don't sweat it

  4. #4
    Carbonic's Avatar
    Join Date
    Sep 2011
    Location
    Omaha, Nebraska
    Posts
    448
    +1
    32
    Quote Originally Posted by VXRBlue View Post
    Under warranty if new. Its the dealers problem don't sweat it
    Do you live in the Sioux City area? Just asking because of the Nebraska/Iowa/South Dakota listed under location.

    Sorry to derail..

  5. #5
    Take a deep breath it is prob something very simple. I would say plugs also, its a great ski dont worry about it. I know it sucks to buy something and it be messed up.

  6. #6
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Are the rpm's high and cavitating, or are the rpm's low.

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    no way yamahas are bullet proof and never play up just ask yoyo sorry mate hope you get it sorted an uneducted guess would likely be plugs or clutch.

  8. #8
    64physhy's Avatar
    Join Date
    Aug 2010
    Location
    Weatherford, TX
    Posts
    1,725
    +1
    168
    If it's revving high and cavitating, you probably have something stuck on the prop. I know you said you checked it, but if even a small chunk of a stick is stuck on the impeller, you probably won't be able to see it, and it will cause this to happen. This happened to me. I checked several times and couldn't see anything and thought I had tweaked the prop. While I was limpiing it home at 5 MPH, it finally decided to come dislodged after several miles.

  9. #9
    Mine is new as well. After hour and a half it died. Let it sit for 30 minutes it ran again. But it would not idle. Motor shook like hell and felt like it was going to drop out the bottom

    Turned out one of the seals in the fuel injector had not been installed right at the factory. Would have never been able to see the problem until we took the cover off the engine. Dealer fixed it the same day and followed up with two phone calls after to make sure I was happy. Kudos to GA Checkpoint Yamaha for great service. Now the machine runs great.

  10. #10
    AmishFZS's Avatar
    Join Date
    Jun 2012
    Location
    Dar Es Salaam, Tanzania
    Posts
    134
    +1
    1
    I had a similar issue with my 2011 FZS, my engine would not start 0 hours on the clock. After hours of trying to figure out the problem, came to know the injectors were clogged with dirt. removed all and cleaned. As soon as i put them back on it the engine started right up. Putting it in the water, i wasn't getting the power it needed. Followed the steps again, and one injector got clogged again. Once cleaned. now this baby is running like a champ.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FX SHO Instantly reaches 5500 Rpm then slowly tops out at 6300.
    By nickwhomer in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 07-20-2016, 02:13 AM
  2. 2010 FX SHO Cruiser any issues out there?
    By Kirk1964 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 10-03-2014, 12:37 PM
  3. 2010 FX SHO - Cavitation All Gone and New Top End
    By VinceC in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 11-24-2012, 03:39 PM
  4. WTB 2010 FX SHO new take off Stock prop
    By dso8950 in forum Yamaha Classifieds
    Replies: 3
    Last Post: 11-12-2011, 02:58 PM
  5. What is the cost of a brand-new 2011 FX SHO/Dealer Cost?
    By Baddog72 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 04-24-2011, 01:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •