Results 1 to 3 of 3
  1. #1
    97 Kawasaki STX 1100
    Join Date
    May 2010
    Location
    Idaho
    Posts
    163

    98 kawasaki stx 750 no start issue help please

    Hi guys, Thanks for reading my post... Just spent 4 days on the lake vacationing. Took our 2 jet skies ones a stx 1100 and the other the stx 750 in question... Both skies ran great until the last day... Funny but we were on our way to the boat launch to pull the skies out when the 750 died... I guess that was lucky ! Our trip was over... Anyway! The 750 was running great we were just cruising along when all of a sudden the 750 started to bog down and then stalled... My wife was riding it... I checked gas and we still had a 1/2 tank... She had tried to restart but all the engine did was turn over... I told her to stop and jumped on the ski myself... When I went to turn it over all it did was click click and wouldn't turn over... I was thinking charging issue and maybe thew ski drained the battery... Towed it back to the doc and pulled the skies... While we were packing up camp about a hr later I tried turning the engine over again on the trailer this time it turned over but slow... I checked the battery after getting home and it still showed 12.7 volts... I went ahead and thru a charge on it anyway and pulled the spark plugs... The electrodes look ok and I still have compression in both cyclinders... Doesn't look like Im getting spark though... I wanted to check the stator and was looking for some ohm readings or a manual for the 750... Any help would be appreciated...

    Oh by the way yes I'm a mechanic and have tools... Long time member ....

    Thanks in advance...


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    Look at the easy stuff first. It's not at all uncommon for a battery cable to come loose, at either end. Vibration, jumping, etc. can cause this.

    After that, you might pull the starter and clean the commutator & replace the brushes.

  3. #3
    97 Kawasaki STX 1100
    Join Date
    May 2010
    Location
    Idaho
    Posts
    163
    Quote Originally Posted by steve45 View Post
    Look at the easy stuff first. It's not at all uncommon for a battery cable to come loose, at either end. Vibration, jumping, etc. can cause this.

    After that, you might pull the starter and clean the commutator & replace the brushes.
    Bad news I need a crankshaft with pistons standard bore anyone got what I need? front seal blew out... Seized rod bearing... Its repairable but I was thinking I need it running today and hoping it would be cheaper..... to buy used..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, Kawasaki x2 750 not starting
    By switchtele in forum Kawasaki PWC Performance (2-stroke)
    Replies: 10
    Last Post: 09-10-2016, 06:29 PM
  2. 2000 Kawasaki STX 1100 DI Starting issues
    By druethe in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-28-2015, 07:00 PM
  3. Need help with 1995 Kawasaki STX 750
    By jtswatertoy in forum Kawasaki Projects
    Replies: 1
    Last Post: 09-07-2013, 11:06 PM
  4. 98 stx 750 no spark
    By bykrjr in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 08-17-2011, 08:47 PM
  5. Replies: 15
    Last Post: 09-22-2010, 12:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •