Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2012
    Location
    Plainfield IL
    Posts
    23

    Hopefully a quickie on a prop change

    Changing a prop on my 1100 venture,came apart perfect and during reassembly I feel what I think is a seal causing resistance when installing the driveshaft back into the pump, while pushing in I am spinning driveshaft can feel it engage then a soft resistance. I'm assuming there is a rubber boot or seal that will seat itself but just looking for someone that's been there before. I can assemble everything fully but I have to slightly push it in to install the long bolts? thanks in advance


  2. #2
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    kinda sounds like the splines are hydrolocking with grease. pull a little grease out and it should slide in all the way.

  3. #3

    Join Date
    Jul 2012
    Location
    Plainfield IL
    Posts
    23
    I did clean off grease and think seal may have been issue but tightened bolts and put 3 hours on without and problems so I would say I'm good Thanks for your help

  4. #4
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    Quote Originally Posted by Cutlass View Post
    kinda sounds like the splines are hydrolocking with grease. pull a little grease out and it should slide in all the way.
    1++ to that..........the 155 pump also uses a bronze bushing for added support that can throw 'feel' off, as compaired to earlyer yami pumps that don't.. glad you sorted this out and are rideing..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pitching the stock prop (record speed on stock prop?)
    By engineermike in forum 4-Tec Performance
    Replies: 21
    Last Post: 08-03-2008, 05:11 PM
  2. prop change
    By polaris_man in forum Polaris PWC Performance
    Replies: 2
    Last Post: 04-04-2008, 04:04 PM
  3. Need prop change instructions
    By fairlanex in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-24-2007, 06:58 AM
  4. 10 Hrs. on RXP oil change??
    By RXPNJ in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-09-2006, 08:55 AM
  5. How many mm's is the impeller alen bolt on the prop?
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 09-22-2005, 09:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •