Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    2004 polaris msx140 2stroke

    the bike ran fine then it was parked for a week or two when tried to start again wouldnt start. i checked injector pulse with noid lights and spark all are there, when i check fuel delivery it just pulses fuel out as i turn it over, i believe these should kick the fuel pump on steady once the motor begins to turn over.?? lie most fuell injected systems cars etc..

    All that said if i poor some fuel in the intake it fires up and will keep running on its own fuel and reving fine aslong as i dont let it get to idle.. then it will die if idle
    anyone have a clue as to why??
    thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Fuel pump is electric. Fuel should flow whenever engine is cranking or running.

    Check fuel pressure at schrader valve tee. Should be over 20 PSI when engine is cranking or running.

    See my signature links for more Ficht fuel injection info.

    Note:Ficht fuel injector's are NOT like automotive fuel injectors. Among other things, they require over 20 volts to operate.

    Check voltage on injector White/Red wires while cranking, with all injector's plugged in. Should be over 20 volts, and 40+ volts when running.

  3. #3
    ok will do. but thats what im saying the fuel should flow steady for so many seconds once it kicks on but instead its just pulsing while turning over

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by sr240 View Post
    ok will do. but thats what im saying the fuel should flow steady for so many seconds once it kicks on but instead its just pulsing while turning over
    Is the fuel tank nearly empty?

    If there is enough fuel depth then the flow should be steady. You can ground the fuel pump Brown wire to run the fuel pump without cranking the engine.

    It is possible that the actual electric pump has failed.

  5. #5
    ok ya im gonna try to jumper the pump and see what i get. i figure the pump works because it runs aslong as you are keeping it reving above idle, below that the pump doesnt kick on steady like its the electronics that kick it on when it sees the motor is spinning

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    You may have more than one problem happening. Any time a Ficht engine does not want to idle I suspect the TPS could be failing as that is a common failure mode.

    Ensure the electrical connections are all clean and tight. There is a fuse or circuit breaker somewhere for the fuel pump, make sure it is clean and tight connections. Same with the grounds.

  7. #7

    Join Date
    Jun 2008
    Location
    windsor ont
    Posts
    640
    +1
    8
    fuses hang in the wiring harness just above the starter solonoid

  8. #8
    as far as i can tell the regulator has fell off what kawasaki reg do yall use? but even with fuel pressure it doesnt start on its own or idle at all just with starting fluid will it start and like before will run while revving it only

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Kawasaki part numbers can be found via my signature links. And there was a very recent post in another thread describing the installation.

  10. #10
    Ok I got the kawi regulator I installed it. The old one had fallen off. But still the bike won't start unless u pour gas or starting fluid down the throttle bodies, then it still won't idle only will run if u rev it and keep it revved

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 Polaris MSX140 for sale
    By codeman671 in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-23-2008, 02:02 PM
  2. 2004 Polaris General Model Info
    By 1996SLTX in forum Polaris Open Discussion
    Replies: 1
    Last Post: 01-13-2008, 02:24 AM
  3. 2004 Polaris msx 150 plugs turned silver after ten minutes help
    By Joe dana in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-16-2007, 11:51 PM
  4. 2004 Polaris MSX 110 - is it good?
    By sergiyk in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-05-2007, 05:11 PM
  5. 2004 Polaris virage 1
    By larryndog in forum Polaris Open Discussion
    Replies: 2
    Last Post: 02-24-2007, 02:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •