Results 1 to 4 of 4
  1. #1

    SCOM help please instructions are confusing

    according to http://www.rivaracing.com/instructio...90_scom_10.pdf

    it says

    go to LAST page to complete install but on last page there is nothing about install. I have 260as 2011 model.

    I do have VTS

    Here is picture of my wires so much different from theres can anyone tell me how to plug this in sense they claim my jetski is already wired for it.
    I connected it but the seadoo only have 5 wires and scom has 6 on the plug.
    Click image for larger version. 

Name:	photo(2).jpg 
Views:	107 
Size:	63.5 KB 
ID:	277442



    1. If any of the below listed Sea-Doo Modules have been installed on your craft you only need to
    mount the supplied S.C.O.M. unit and plug it into the existing module (inline). Proceed to page 2
    for mounting instructions. DO NOT FOLLOW STEPS FOR WIRING. Your craft is already wired
    for the S.C.O.M. unit. After mounting proceed to last page to complete installation.
    Sea-Doo Modules:
    • X Package Module
    • Ski Module
    • Variable Trim System Module
    • Cruise Control and Ski Module


  2. #2
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Quote Originally Posted by kalamad View Post
    according to http://www.rivaracing.com/instructio...90_scom_10.pdf

    it says

    go to LAST page to complete install but on last page there is nothing about install. I have 260as 2011 model.

    I do have VTS

    Here is picture of my wires so much different from theres can anyone tell me how to plug this in sense they claim my jetski is already wired for it.
    I connected it but the seadoo only have 5 wires and scom has 6 on the plug.
    Click image for larger version. 

Name:	photo(2).jpg 
Views:	107 
Size:	63.5 KB 
ID:	277442



    1. If any of the below listed Sea-Doo Modules have been installed on your craft you only need to
    mount the supplied S.C.O.M. unit and plug it into the existing module (inline). Proceed to page 2
    for mounting instructions. DO NOT FOLLOW STEPS FOR WIRING. Your craft is already wired
    for the S.C.O.M. unit. After mounting proceed to last page to complete instal
    Sea-Doo Modules:
    • XPackage Module
    • Ski Module
    • Variable Trim System Module
    • Cruise Control and Ski Module
    From what I understood when I did mine, it was add on modules, not factory
    So you need to wire the extra wire included.

  3. #3
    ATNryan's Avatar
    Join Date
    Apr 2012
    Location
    River Crew CT
    Posts
    695
    +1
    75
    Quote Originally Posted by surferd15 View Post
    From what I understood when I did mine, it was add on modules, not factory
    So you need to wire the extra wire included.
    Yeah, the wording in the instructions can be very misleading. Thought it was just plug and play. Exactly why I mounted mine, realized it, and popped it out. Glad I did too so I can still sell it.

  4. #4
    Quote Originally Posted by ATNryan View Post
    Yeah, the wording in the instructions can be very misleading. Thought it was just plug and play. Exactly why I mounted mine, realized it, and popped it out. Glad I did too so I can still sell it.
    ya going to sell mine I guess sense its to hard to install

    funny though I installed the grate impeller and airfilter. Still though even with stage 1 kit my ski only goes 7000 rpm 55mph on bad day 59mph on good day

    stock it used to go 69 haha

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ok, am I stuck with this Riva SCOM? Help please.
    By dpracing in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-10-2013, 09:09 PM
  2. 900zxi rpms are fine but runs slow. HELP PLEASE!
    By flnsx in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 09-23-2007, 10:36 PM
  3. RXT 2005 Loose Hose - HELP PLEASE
    By BrAinZ in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-12-2006, 12:28 PM
  4. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM
  5. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •