Results 1 to 3 of 3
  1. #1

    Join Date
    Jul 2012
    Location
    NJ
    Posts
    2

    2003 xlt1200 lean midrange after dplate install

    I have installed a dplate with chip, rebuilt the carbs, and replaced the rings with OEM's. High adjuster is @ 2 out and low @ 1 1/8. Ski idles perfectly, accelerated to 1/3 throttle fine, and has a great top end (60+). Midrange is lean and bogs. I can get through this with the use of the choke. Popoff pressure? I used the original brass colored spring when doing the carbs. Is this a popoff pressure problem or will opening the low speed adjuster another 1/8-1/4 solve this problem?


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by jcc2 View Post
    I have installed a dplate with chip, rebuilt the carbs, and replaced the rings with OEM's. High adjuster is @ 2 out and low @ 1 1/8. Ski idles perfectly, accelerated to 1/3 throttle fine, and has a great top end (60+). Midrange is lean and bogs. I can get through this with the use of the choke. Popoff pressure? I used the original brass colored spring when doing the carbs. Is this a popoff pressure problem or will opening the low speed adjuster another 1/8-1/4 solve this problem?
    i use the dull silver spring and turn the lows to 1 3/4 turns and the highs to 2 and you should be fine.

  3. #3

    Join Date
    Jul 2012
    Location
    NJ
    Posts
    2
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    i use the dull silver spring and turn the lows to 1 3/4 turns and the highs to 2 and you should be fine.
    Jim, thanks for the help! I'll give it a try.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 Xlt1200
    By Mizelra in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 12-10-2006, 03:39 AM
  2. SMoke after Jetworks install
    By PuprleNuprleGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 32
    Last Post: 07-27-2006, 03:21 PM
  3. Sealants for Jetworks + DPlate install?
    By PuprleNuprleGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 07-19-2006, 06:20 PM
  4. Steering alignment after wedge install
    By excess in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-18-2006, 04:46 PM
  5. Upgrading clutch on an 06 after impeller install
    By excess in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-16-2006, 10:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •