Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    03 MSX 140 no power

    I just purchased a 03 MSX 140 this past weekend. It starts and idles great but doesn't have much power out of the hole. At WOT it runs about 7100 rpm then drops down to about 6300 then back to 7100. I checked the fuel pressure and got 26-27 psi. Any ideas on what could be casuing this? I am new to these injected motors they are a lot different than my older seadoos. Also I should mention that I wasn't getting any engine codes or any lights.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    TPS is often a suspect.

  3. #3
    Quote Originally Posted by K447 View Post
    TPS is often a suspect.
    Is there any good want to test it before just dumping money into it?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by JeepMann View Post
    Is there any good want to test it before just dumping money into it?
    There is no reliable test for a TPS other than to install a known good TPS and see if the problem goes away.

    You can test a bad TPS with a meter and sometimes prove it is bad, but you cannot meter test a TPS and prove it will still be good when mounted on a running, vibrating, hot engine.

    This is also why it is a good idea to have a spare TPS on hand. If you ever suspect the TPS is failing, swapping in a new TPS is a quick way to validate the diagnosis.

    Even if your current TPS is actually still good, the money spent on a new TPS is not wasted. Put that spare TPS in some bubble wrap in your watercraft toolbox, as you never know when you will need it.

  5. #5
    Quote Originally Posted by K447 View Post
    There is no reliable test for a TPS other than to install a known good TPS and see if the problem goes away.

    You can test a bad TPS with a meter and sometimes prove it is bad, but you cannot meter test a TPS and prove it will still be good when mounted on a running, vibrating, hot engine.

    This is also why it is a good idea to have a spare TPS on hand. If you ever suspect the TPS is failing, swapping in a new TPS is a quick way to validate the diagnosis. So even if your current TPS is actually still good, the money spent on a new TPS is not wasted. Put it in some bubble wrap in your watercraft toolbox, as you never know when you will need it.

    OK thanks, I will see if I can find one to try out.

  6. #6
    OK I have made calls to dealers around me, and a few places on online and no one has these TPS. Any good places to check out?

  7. #7

    Join Date
    Jun 2012
    Location
    Parma Ohio
    Posts
    38
    PartsPitStop.com has them. The part number is 2202740. Made by Honeywell
    $68.87 Not really sure if thats a good price or not, I just ordered myself one a few days ago

  8. #8
    I installed a new tps but no change in the way it runs. No clue where to turn from here without dumping a ton of money in it. I may just need to sell
    It as is.

  9. #9

    Join Date
    Jun 2008
    Location
    Bullhead City AZ.
    Posts
    451
    +1
    2
    Where are you located? I have Digital wrench

    Quote Originally Posted by JeepMann View Post
    I installed a new tps but no change in the way it runs. No clue where to turn from here without dumping a ton of money in it. I may just need to sell
    It as is.

  10. #10
    Waterford, mi...what is a digital wrench?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03' msx 140 ho no spark no fuel to cylinders
    By PolarisFreak1234 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 08-07-2012, 05:37 PM
  2. [email protected] 03 msx 140 no start
    By b&v in forum MSX/Matrix
    Replies: 3
    Last Post: 07-11-2010, 08:58 PM
  3. '03 msx 140...deal? or no deal?
    By fastexas in forum MSX/Matrix
    Replies: 8
    Last Post: 11-14-2007, 02:45 PM
  4. 03 msx 140
    By Jayman in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-24-2007, 11:49 PM
  5. Thoughts/potential problems on '03 MSX-140 D.I.
    By Nefarious in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-27-2007, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •