Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    Plz Help! 2007 RXT issues this season and could sure use some help?

    If anyone has any input out there, been a member since 07 and no real problems with the 07RXT till this year. Put the ski to bed here in PCB Fl. last season and can't seem to wake it up. Runs fine on the hose but will not run in the water. No failure SC fresh back from Jerry and slip good with his washers. Injectors and coils good. 3 sets of fresh plugs and new fuel in the tank(empty for the winter and f/stable in new gas.) I would like to know of any good mechs in my surrounding area or dealers with good reps. Also where I can pick up a adapter for my comprss. guage and if anyone close has a leakdown test kit. RPMS on trl. 8000, in water mabe 3000 whith black smoke. Looked down all cylinders with borescope and shinny clean with good valves. All three plugs come out with oil residue like oil is fouling them out. I have tried all I can so far, without some more tools, and just want some feedback or area help? I think that's about it till I get some questions or feedback, and its way to warm here to ride bikes during the day anymore.


  2. #2
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    If this is Jim, I will be back in town next week. Doing the charleston thing right now. We will fit up for a compression test and see what you have leaking or not. If you cant wait call tadpole at RandR marine in lynn haven. -Hal

  3. #3
    Codeman666's Avatar
    Join Date
    Aug 2007
    Location
    sunny south florida
    Posts
    179
    +1
    8
    how does your rxt idle is it between 1780-1940rpm? in and out of water? does it run smoothly through the rpm range out of water or does it seem rough and/or has hesitation?

  4. #4
    Quote Originally Posted by sHALlow View Post
    If this is Jim, I will be back in town next week. Doing the charleston thing right now. We will fit up for a compression test and see what you have leaking or not. If you cant wait call tadpole at RandR marine in lynn haven. -Hal
    Hey Hal, yes it's Jim and I can wait for you. I am over on sunset ave and still have same phone # as always or just hit me back here and I will get it to you. Thanks, just short on tools for the newer skis.

  5. #5
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    cool man. i also have a spare walbro and fuel filters if we need to change yours out. you might want to pull a spark plug and take it to autoparts store to see if they have the right fit for the threads for a comp tester.

  6. #6
    Quote Originally Posted by Codeman666 View Post
    how does your rxt idle is it between 1780-1940rpm? in and out of water? does it run smoothly through the rpm range out of water or does it seem rough and/or has hesitation?
    I think it is more around 1300-1780 but will have to check. 97 hrs on motor with clutch back/rebuilt and checked for slip. Seems the rough and/or hesitation in my case, any ideas. I just can't think all 3 cylinders had rings go at once and valves look fine but will have to pull valve cover to be certain. Saltwater boat so some rusty hardware but always run ski mildly and at different throttle speeds. Thanks for the reply. Anyone else out there have any same problems as this, cause I have searched the forum from one end to the other with no luck?

  7. #7
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    jim, i forgot about the oil problem. did you specifically pay for and ask Jerry to install new seals in the SC when you had it rebuilt? if not you may want to pull the hose from the SC to throttle body off and see if there is any oil in there. whats the oil level like? it should be 1/2 to 2/3 up the two bends when warm (and level on the trailer). idk with the rpm problem you are having i am thinking fuel or electrical problem.

  8. #8
    Quote Originally Posted by sHALlow View Post
    jim, i forgot about the oil problem. did you specifically pay for and ask Jerry to install new seals in the SC when you had it rebuilt? if not you may want to pull the hose from the SC to throttle body off and see if there is any oil in there. whats the oil level like? it should be 1/2 to 2/3 up the two bends when warm (and level on the trailer). idk with the rpm problem you are having i am thinking fuel or electrical problem.
    Double checked all that with Chip, problem somewhere else I'm thinking. Glad your wheels are turning on this, been fightin this on an off this season and hoping I won't have to pull the motor and kill the season.

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    What does the anti freeze level look like?????Is it low or at the line???What color are your plugs when you pull them out???Are they shiny black???

  10. #10
    Was a little afraid of this kinda question but thats why I am asking. To be honest it has always been about a half inch below line with the heat down here but need to double check and see if it's lower now, if so not much. The plugs are more burnt then shiny but tell me where you are going with this, I have seen you help many others on here? Peoria boy myself snoman, been down here 20 yrs and there are all kinds of fresh water creeks to run like you are on a crotch rocket not to mention our blue water and white sand beaches.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 2007 RXT STOCK Exit Nozzle and Steering Nozzle
    By gbayus in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-26-2015, 05:00 PM
  2. New to this forum and was looking for some help on a 2004 KAWASAKI STK-12F
    By jcard71 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 03-23-2015, 07:38 AM
  3. Replies: 0
    Last Post: 07-19-2012, 08:35 AM
  4. Replies: 1
    Last Post: 07-26-2011, 12:15 PM
  5. 1st Day out this season and engine fails :(
    By BrAinZ in forum Sea Doo Open Discussion
    Replies: 19
    Last Post: 05-08-2007, 03:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •