Results 1 to 6 of 6
  1. #1

    96 sl 900 stator coil test

    Hi there. I just did a test on my stator to see if that is the reason i am not getting any spark. My 96 sl900 test went as follows

    balck to purple supposed to get 1200 ohms and I got 1200 ohms
    Black to Gray supposed to get 88 or 140 and i got nothing
    Yellow to Red/Purple suppoed to be .75 got .7
    Yellow or Red/Purple to engine block no connection I got no connection.
    Spark plug cap to engine gound got 7200 Ohms

    As you can see the Black to Gray is the one reading that didn't match up.

    Does this mean the stator is gone.

    i did do the CDI Voltage test I found on the forum and everthing came out good.

    Thanks for any help.


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,572
    +1
    35
    Yes,that blk-grey reading is a problem. You could check the wire going into the stator housing to make sure it is not broken inline somewhere.

    According to your readings it is the original style ignition,so it will need the ign update kit to get a new stator.

  3. #3
    Thanks Casey, I will check that out. One other question. When you do the ign update kit do you have to replace the flywheel as well or does the new stator fit with the existing flywheel.

    Thanks

  4. #4
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,572
    +1
    35
    No need to change the flywheel.
    The update "kit" is actually a better design stator and CDI. ( they can only be used together )

  5. #5
    So I just did the udate kit for the stator and CDI. got it out of Babbits, great service. Anyway, I have read alot of posts on Timing. do you have to re-time the enginge after you install the new Stator CDI update?

  6. #6
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,572
    +1
    35
    In thoery,you should'nt have to adjust timing. But you absolutely need to check it-it could be off.

    It appears the 2 cylinder update CDI's are some how different and have needed to be adjusted (several reports of them being off by 10 deg) it's very possible the 3cyl could be off also.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 sl 900 stator
    By Dvandy1 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-01-2010, 10:27 AM
  2. Is a 96 sl-900 worth 550 ?? Top-speed???
    By gvnitup in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-07-2007, 06:29 PM
  3. 96 sl 900
    By mixedguy in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-08-2007, 05:38 PM
  4. Where can I get a deal on parts for a 96 SL 900???
    By Alberta Boy in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-18-2007, 01:25 PM
  5. 96 SL 900 CDI and stator
    By S12L00X in forum Polaris PWC Performance
    Replies: 0
    Last Post: 03-13-2007, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •