Results 1 to 3 of 3
  1. #1

    1998 polaris sltx missing above half throttle

    i have a ninety eight sltx the on board display is not working and it is cutting out above half throttle i have checked spark and compression and both seem to be fine. i am new to pwcs and not sure where to go from here any thoughts


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Sounds like the RPM limiter may be active. Since the display is not working you need to check for faults yourself.

    Low Oil level, Low fuel level, Engine HOT signal?

    Chck the fuse for the MFD. if MFD is getting power and ground but is not working then unplug the display. A dead display can mess with the ignition system.

    See my signature links for more info

  3. #3
    Thanks for the tips ill try those tonight thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 1998 Polaris SLTX - MINT COND.!!
    By 32DegH2O in forum Polaris Skis
    Replies: 17
    Last Post: 03-31-2013, 11:19 AM
  2. FS 1998 Polaris SLTX Part Out
    By Seadooracer9 in forum Polaris Classifieds
    Replies: 8
    Last Post: 01-16-2012, 07:22 AM
  3. 1998 Polaris sltx 1050 ignition coil just clicking help ???
    By smoked134134 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-18-2011, 04:10 PM
  4. 62T Engine Cutting Out above half throttle
    By Beerme in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-03-2011, 08:37 AM
  5. SLTX Bogging at Half Throttle
    By kl7741 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-14-2009, 11:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •