Results 1 to 3 of 3
  1. #1

    Join Date
    Nov 2008
    Location
    Verona, VA
    Posts
    10

    Lost power and water

    I have a 1998 XL760 waverunner. Engine was rebuilt 3 years ago. Recently, the exhaust got louder, only half power and noticed more water inside the hull than the syphon will draw out. I suspect maybe an exhaust gasket, which would account for the noice, but would it also induce more water into the hull? Any suggestions would be helpful.


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by gillman81 View Post
    I have a 1998 XL760 waverunner. Engine was rebuilt 3 years ago. Recently, the exhaust got louder, only half power and noticed more water inside the hull than the syphon will draw out. I suspect maybe an exhaust gasket, which would account for the noice, but would it also induce more water into the hull? Any suggestions would be helpful.
    A gasket or hose leaking or the manifold or water box. Yes you will also get water into the hull.

  3. #3

    Join Date
    Jul 2012
    Location
    Miami, Florida, United States
    Posts
    36
    Yes the best way to check is to remove the seats and run it on the hose you will see exactly where its coming from and it can be as easy as a loose clamp or needing new exhaust gaskets

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Genesis Polaris 1200 lost power and blew steam???
    By xavierspl in forum Polaris PWC Performance
    Replies: 9
    Last Post: 07-04-2016, 10:44 PM
  2. 2009 yamaha Vxr With 40 . LOST Power and cavitation PLEASE HELP
    By mannyk727 in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-02-2015, 08:43 AM
  3. Give a engine bath with purple power and water
    By Seakid in forum Polaris Tech Tips and Info
    Replies: 7
    Last Post: 04-20-2015, 09:06 PM
  4. 2000 STX DI - Engine lost power and eventually stalled - now won't crank
    By Leder in forum Kawasaki PWC Performance (2-stroke)
    Replies: 19
    Last Post: 07-16-2013, 09:51 PM
  5. Lost power and making water fast
    By RightOnTarget1 in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 03-01-2010, 09:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •