Results 1 to 5 of 5
  1. #1

    Virage I Check Engine Light

    Hello All.

    My Virage I is giving me a headache today. I started her up and as soon as I did I get a Check Engine Light. It wont go above 1000 RPM either.
    I am going to hit up Radio Shack tomorrow to get a LED to do the EMM Code Test.

    Just wanted to see if there is anything else I can be checking in the mean time.
    It fires up perfectly, just throws the code.
    Put Fresh Fuel in, New Spark Plugs. Both are firing also.

    Just been hitting my head against the hull literally.


  2. #2
    Well Turns out I am getting
    Errors 12 and 14
    12 THROTTLE POSITION SENSOR CIRCUIT MALFUNCTION
    14 THROTTLE POSITION SENSOR ABOVE EXPECTED RANGE

    I found an original TPS on Ebay, anything else I should be on the lookout for ?

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Make sure the TPS connector pins are clean and grease free, both sides of the connection.

    Make sure TPS Is properly installed. If it is the older style with a rubber nub bumper on a short metal arm, make sure the bumper is present.

    Also make sure the TPS return spring is correctly positioned and the throttle cable has the correct amount of slack at idle position.

    Do NOT overtighten the TPS bolts.

  4. #4
    Well got the new part in. I guess when my old dealer replaced the tps back in the day they didn't do it right.
    When unscrewing the old bolts. The bottom one the spacer thread on the throttle is cracked..
    Where can i find those 2 spacers that the tps bolts screw into..
    Thanks

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by King908 View Post
    Well got the new part in. I guess when my old dealer replaced the tps back in the day they didn't do it right.
    When unscrewing the old bolts. The bottom one the spacer thread on the throttle is cracked..
    Where can i find those 2 spacers that the tps bolts screw into..
    Thanks
    Considering the very low torque specified for those bolts I would guess the bolts were way over tightened.

    You may need to find a parted out throttle body.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 polaris virage i - Check engine light
    By Markyob2 in forum Polaris Tech Tips and Info
    Replies: 18
    Last Post: 06-16-2016, 07:21 AM
  2. 2002 Virage TXI Check Engine Light, Pulled Codes
    By Harsax13 in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 08-25-2015, 07:20 PM
  3. 2002 Virage i Check Engine Light
    By bnkeaane in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-12-2010, 07:06 PM
  4. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM
  5. Check Engine Light
    By meeper in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-27-2005, 04:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •